Closed Bug 1868914 Opened 3 months ago Closed 21 days ago

Search option "Match Diacritics" is mislabeled

Categories

(Toolkit :: Find Toolbar, defect)

Firefox 113
defect

Tracking

()

RESOLVED DUPLICATE of bug 1707842

People

(Reporter: rees, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/113.0

Steps to reproduce:

Type control-F to search for a string. Now type in a dash, for example "–" (en dash).

Actual results:

The search will stop not just on dashes, but on hyphens too. To get it to stop only on dashes I must select the mis-labeled "Match Diacritics" option.

Expected results:

The search should only stop on dashes, if that's what I entered as my search text. But if I need to select an option to get that behavior, the option should be labeled something obvious, not "Match Diacritics", which isn't just misleading, it's wrong. The distinction between dash and hyphen has nothing to do with diacritics.

The Bugbug bot thinks this bug should belong to the 'Firefox::Search' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Search
Component: Search → Find Toolbar
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Duplicate of bug: 1762496
Resolution: --- → DUPLICATE

This is not a duplicate of bug 1762496. That bug says that search for hyphen incorrectly returns dashes. This bug is about the label on the "Match Diacritics" checkbox. The label is wrong, that's not what the checkbox does. I'm not asking for a fix to the problem described in bug 1762496.

Status: RESOLVED → UNCONFIRMED
No longer duplicate of bug: 1762496
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago21 days ago
Duplicate of bug: 1707842
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.