Closed Bug 1869042 Opened 7 months ago Closed 2 months ago

Meet stopped working with media.devices.enumerate.legacy.enabled = false

Categories

(Core :: WebRTC, defect)

Firefox 120
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: jib, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image image.png

Meet stopped working this week for Firefox folks who have manually preffed off "legacy" enumerateDevices.

STRs:

  1. In about:config, flip media.devices.enumerate.legacy.enabled to false.
  2. Go to https://meet.google.com/ and start an instant meeting.

Expected result:

  • Seeing self-video in the lobby

Actual result:

  • Either a black screen, or "Camera not found".
  • In web console: Uncaught (in promise) Error: Sr

Safari still works for some reason, even though it also has non-legacy enumerateDevices.

This likely points to an issue in Meet, but filing it here to keep track of it.

Summary: Meet stopped working with → Meet stopped working with media.devices.enumerate.legacy.enabled = false
Duplicate of this bug: 1869748

The severity field is not set for this bug.
:mjf, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(mfroman)
Flags: needinfo?(mfroman) → needinfo?(jib)
Severity: -- → S3
Flags: needinfo?(jib)

Google Meet now works with media.devices.enumerate.legacy.enabled set to false as well as when PipeWire camera backend is used.

Were you testing on a system with v4l2 camera available or with only pipewire?

I've just tested with latest build from bookmarks/central, with media.devices.enumerate.legacy.enabled set to false and media.webrtc.camera.allow-pipewire set to true on a system with only pipewire camera available (Pi 4 on Bookworm with a CSI camera) and this still doesn't work for me.

(In reply to David Turner from comment #4)

Were you testing on a system with v4l2 camera available or with only pipewire?

I've just tested with latest build from bookmarks/central, with media.devices.enumerate.legacy.enabled set to false and media.webrtc.camera.allow-pipewire set to true on a system with only pipewire camera available (Pi 4 on Bookworm with a CSI camera) and this still doesn't work for me.

Does PipeWire camera work for you somewhere else?

I tested with both v4l2 and PipeWire, it works in both cases for me.

It's a meet issue to make non-legacy mode work. Current status seems to be that first-use works OK, but revisits don't.

I'm using Firefox 125.01 Flatpak and the camera works with and witout the media.devices.enumerate.legacy.enabled flag. However, it is very slow when I move my head (tracing) and is slightly out of focus.

Apologies. I forgot to mention that I'm running Fedora 39 Gnome Wayland session without any extensions or mods except fractional scaling. Firefox is running in Wayland mode as well.

If you see a camera issue in Firefox that you don't see in other apps, please file a new bug. This is about something else.

I've just tested with Firefox 125.0.1 on Raspberry Pi OS on a Pi 4 with a CSI webcam, libcamera/pipewire only and no V4L2. Meet seems to work with both media.devices.enumerate.legacy.enabled enabled and disabled, on both first visit and repeat visits in both cases.

With media.devices.enumerate.legacy.enabled disabled repeat visits do show a "Something is wrong with your camera or microphone" message after you allow the camera, but after you dismiss that message the camera loads and works fine.

This all also works in Firefox 122 so it looks like Meet has fixed it.

Looks like this was a Meet bug, so I'm closing it out now that they've fixed the issue.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: