"Save As" hangs Mozilla for 10 to 30 seconds for each file saved

RESOLVED DUPLICATE of bug 145851

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 145851
16 years ago
14 years ago

People

(Reporter: Douglas Godfrey, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126

"Save As" hangs Mozilla for 10 to 30 seconds for each file saved.

This happens every time for any file for any web site.




Reproducible: Always

Steps to Reproduce:
1) Go to any web site.
2) Select any file or downloadable image.
3) Select "Save As" or "Save Link Target As".
4) Click the "Save" button in the file dialog.
5) Mozilla hangs with a ranbow cursor for 10 to 30 seconds.

Actual Results:  
Mozilla hangs with a ranbow cursor for 10 to 30 seconds.

The hang is in 2 parts, 5-10 seconds during which the 
save progress dialog is a blank dialog with nothing 
filled in followed by another 5-20 seconds after the 
save is complete before Mozilla responds to any input.

During the hang Mozilla uses less than 1% CPU.


Clicking on any other Mozilla window is ignored until the
Save progress bar is no longer blank.

Expected Results:  
Mozilla shuld remain responsive while the save takes place in the background.

Comment 1

16 years ago
Hi I have the same Problem with Linux Mozilla 1.2.1.
as far as i can remember the older version did not have such a delay while
saving files. Looks like a general Problem with 1.2.1.

Comment 2

16 years ago
Hi Douglas,

i could reduce waiting time by removing the old rubish from the Download Manager.
Crtl A and then Remove from List.
I had thousend of old downloads in this List.

I hope this helps.

Bender

Comment 3

16 years ago
Douglas, if comment #2 resolves your problem, this is a duplicate of bug 145851.
Please resolve it. Thanks.
(Reporter)

Comment 4

16 years ago
When I open the Download Manager in Mozilla, I get an empty window.
I have the Navigator:Downloads preference set to "Open a progress Dialog"
instead of "Open the Download Manager".

There are NO files listed in the Download Manager so having too many
cannot be the cause of this problem.

Comment 5

16 years ago
Well, there is also a bug about not wrongly displaying the downloads in the dl
manager.
Currently it is supposed to display ALL downloads you ever did (no matter which
kind of progress window is displayed) and I don't think there were none since
end of November.

Please locate the file "downloads.rdf" in your profile folder (the one you
really use, best make a file search for that name) and check its size.
If it is larger than about 200-300 kB it probably does slow things down.
(Reporter)

Comment 6

16 years ago
The "downloads.rdf" file was 1.6 megabytes.

After deleting the "downloads.rdf" file and restarting Mozilla
the slowdown is gone.

Comment 7

16 years ago
Ok, then this is bug 145851. I'm going to do some testing now and then confirm
that other bug.

*** This bug has been marked as a duplicate of 145851 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.