Option to open new window or tab when invoked by OS

VERIFIED DUPLICATE of bug 172962

Status

()

Firefox
General
--
enhancement
VERIFIED DUPLICATE of bug 172962
16 years ago
15 years ago

People

(Reporter: Ian McCall, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

When Phoenix is set as the default browser, cicking on a link in another program
results in the frontmost tab changing its contents to that of the link given.
This loses the existing contents in the tab.

It would be nice to have an option which specifies that a new tab (or Window)
should be opened for URLs from external programs.

This whole report is analogous to IE's "Reuse windows when launching shortcuts"
preference.

Reproducible: Always

Steps to Reproduce:
1. Set Phoenix to be the system's default browser
2. Click on a link in another program (eg. Outlook Express)

Actual Results:  
The frontmost tab loses its contents and is replaced by that of the invoked URL.

Expected Results:  
According to the new preference, it could open a new tab, open a new window or
continue to behave in the existing manner.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 172962 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.