Status

--
major
VERIFIED DUPLICATE of bug 135225
16 years ago
10 years ago

People

(Reporter: WinterWolf007, Assigned: bugzilla)

Tracking

Trunk
All
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

This is a major cross platform bug that affects all Mozilla based browses,
Netscape, Mozilla, Phoenix, Galleon, Chimera, all of them. All one has to do is
highlight any text or text link and than right click on any kind of image or
link to evoke the bug. If you completely highlighted a text link and than right
click the same text link this bug will not show it's nasty self. However, if you
partially highlighted a text link and tahn right click the aprt of thet ext link
not highlgihted it will still show itself. The bug combines the options that
should come up when you right click on highlighted text or text link with the
options that should come up when right clicking on images or links. 

This create many odd options which have no relation to the current action. For
example doing a web search for what some highlighted text says when right
clicking an image or link makes no sense!

This bug can be evoked on any website.

Reproducible: Always

Steps to Reproduce:
1. We will use pclinuxonline.com as the test site for this bug, therefore,
please point your browser to it.
2. First  right click on the links in the navigation bar and check out the
menus, this is how they should look like. Also right click on the top right
header image and check out the context menu.
3. Now highlight some text or a text link, and right click on a link or image,
than stare at the crazy context menu. 

Actual Results:  
The bug combines the options that should come up when you right click on
highlighted text or textlink with the options that should come up when right
clicking on images or links.

Expected Results:  
I expected the context menus for links and images to have the same options as if
no text or text link was highlighted.
Over to XP apps, but I believe this was the explicitly designed behavior in the 
context menu spec....
Assignee: asa → blaker
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
QA Contact: asa → paw
(Reporter)

Comment 2

16 years ago
MAybe it was explicitly designed that way. But, it's designed wrong.

*** This bug has been marked as a duplicate of 135225 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.