Crash when closing mail/news window

VERIFIED DUPLICATE of bug 182803

Status

MailNews Core
Networking
--
critical
VERIFIED DUPLICATE of bug 182803
15 years ago
10 years ago

People

(Reporter: Amir Katz, Assigned: Scott MacGregor)

Tracking

({stackwanted})

Trunk
x86
Windows 2000
stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme?)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

When starting mail/news from quicklaunch and then closing it with File->Close,
Mozilla 1.3 a crashes.

Reproducible: Always

Steps to Reproduce:
1. No Mozilla winodw is currently open
2. Start mail/news from Windows 2000 quicklaunch
3. Read some news
4. Close window with File->Close

Actual Results:  
Crash; feeback agent was activated

Expected Results:  
Not crash ? (:-)

Comment 1

15 years ago
Duplicate of bug 179391 (again ?) ?
(Reporter)

Comment 2

15 years ago
Frederic Bezies asked: "Duplicate of bug 179391 (again ?) ?". Looks like it, but
I did not find it since I looked under product=MailNews. Sorry. Anyway, I can
add what is different than 179391:
1) It's enough to open the MailNews window from QuickLaunch. I did not have a
Navigator windows open.
2) If I start MailNews from the bottom toolbar in Navigator, no crash.

Hope this helps a little.

Comment 3

15 years ago
Have you been connected to a secure newsserver during the session?
Could be bug 182803. Try a new nightly, it's been fixed.
(Reporter)

Comment 4

15 years ago
Yes, it looks like the same bug - accessing a secure newsserver (surprisingly,
it's secnews.netscape.com :-).
So I tried the latest nightly build (mozilla-win32-talkback.zip), but with this
version I cannot open the mail/news window from the QuickLaunch icon. Navigator
and Composer windows do open. Weird. So I cannot confirm that the problem is
fixed with this nightly.
Crashing on quicklaunch means this is almost definately bug 157760.

Reporter, can you provide a talkback ID please?
Whiteboard: dupeme?
(Reporter)

Comment 6

15 years ago
If 'reporter' means me, I'll be glad to help, but pardon my ignorance, how do I
know the Talkback Agent ID?  I did send a report and in the text I specified
this bug ID number.
Oh, yes, you are the reporter. Sorry =)

If you could open up your mozilla directory, and then go to the components
directory, you will see talkback.exe. Run it, and get the talkback ID it will
display in the program (example: TB38247966Q, TB38247901H, etc.) If you could
post that ID, it would be really helpful. Thanks!
(Reporter)

Comment 8

15 years ago
As requested, TB IDs = TB15647727Q, TB15585993X

Comment 9

15 years ago
nssCertificate_Destroy [certificate.c, line 131]
nsNSSCertificate::`scalar deleting destructor'
nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65]
nsSSLStatus::Release
[c:/builds/seamonkey/mozilla/security/manager/ssl/src/nsNSSCallbacks.cpp, line 112]
nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65]
nsNSSSocketInfo::`scalar deleting destructor'
nsNSSSocketInfo::Release
[c:/builds/seamonkey/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp, line 173]
nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65]
nsSocketTransport::`scalar deleting destructor'
nsSocketTransport::Release
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsSocketTransport.cpp, line 1330]
nsSocketRequest::~nsSocketRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsSocketTransport.cpp, line 2729]
nsSocketReadRequest::`scalar deleting destructor'
nsSocketRequest::Release
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsSocketTransport.cpp, line 2713]
nsCOMPtr_base::~nsCOMPtr_base
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 65]
nsOnStopRequestEvent::~nsOnStopRequestEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 295]
nsOnStopRequestEvent::`scalar deleting destructor'
nsARequestObserverEvent::DestroyPLEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 124]
PL_DestroyEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 682]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 657]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 578]
nsEventQueueImpl::ProcessPendingEvents
[c:/builds/seamonkey/mozilla/xpcom/threads/nsEventQueue.cpp, line 392] 
Looks like Hasse gets the prize =)

Reporter:

ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer-sea.exe

That is the link to the latest nightly version of Mozilla. If you would rather
have a more stable version, albeit a bit older, you could try 1.2.1:

http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.2.1/mozilla-win32-1.2.1-installer.exe

Anyhow, this is a duplicate of fixed bug 182803. Be sure to download the latest
build for the fix, and thanks for testing Mozilla!

*** This bug has been marked as a duplicate of 182803 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE

Comment 11

15 years ago
VERIFIED DUPLICATE
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.