Selection of mail messages for deletion quirky with right-click.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: everhart, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Selection of multiple mail messages for deletion has quirks when performing
complex selections with Shift-Click and Control-Click.  Wrong email messages are
deleted when delete function is selected from context menu.

Reproducible: Always

Steps to Reproduce:
1. Use mouse click and then a shift-click to select three messages.
2. Deselect middle choice with ctrl-click.
3. Perform right-click (context menu) on either of the highlighted choices and
choose Delete Message.


Actual Results:  
The last two messages will always be deleted.

Expected Results:  
First and third messages should be deleted.

I'm setting the severity on this item for normal, but it may be more serious if
people use this function to delete spam email (like I do) and end up deleting
important messages instead before reading them.

Updated

16 years ago
QA Contact: laurel → gchan

Comment 1

16 years ago
reporter,
using Xp commercial trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030106
this works for me on imap and pop mail accounts.

I select 3 megs, deselect middle mesg, rt click on one of the remaining
2 selected mesgs and delete and the selected mesgs get deleted.

are you on imap or pop? Know what type of mail server you are using?

maybe try a more current build?

Comment 2

16 years ago
closing as works for me.
If you see this in a more recent
build, please reopen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.