Saving to disk is very slow after a large number of downloads

RESOLVED DUPLICATE of bug 159107

Status

RESOLVED DUPLICATE of bug 159107
16 years ago
14 years ago

People

(Reporter: green_r, Assigned: bugzilla)

Tracking

({perf})

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

If you don't clean out the cache and the history, eventually saving to disk is
very slow on Mac OS X.  I have not had the same problem on Windows.  It seems to
be once downloads.rdf file has reached a certain size (something over 4 MB I
think) saving is very, very slow.  It seems to be directly related to the size
of the file. If you delete the downloads.rdf and the history.dat files manually,
downloads get faster again. 



Reproducible: Always

Steps to Reproduce:
1. Display images
2. Use "Save Image As..."
3. Get downloads.rdf file to over 4 MB
4. Saving gets slower and slower as the file gets bigger and bigger.

Actual Results:  
Saving becomes very slow

Expected Results:  
Save the image quickly and return control to the user.

Since OS X is UNIX, I figure Mozilla should be appending to these files using
cat, then the extra data is simply appended.  It seems that Mozilla is actually
reading the file, then writing it back out again (I'm guessing here, since
saving takes longer each time).

It is also not necessary to have the download manager appear each time you use
"Save Image As ...".  The download manager should only be used where the file is
actually being downloaded, not when it is being simply copied from the cache (or
re-named).

Comment 1

16 years ago
The downloads.rdf part is covered in bug 161783.

Comment 2

16 years ago
Robert, can you still reproduce this problem using a current nightly build?
Keywords: perf
Summary: Save to disk is very slow after a large number of downloads → Saving to disk is very slow after a large number of downloads

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.