Closed Bug 1873578 Opened 6 months ago Closed 4 months ago

Over-specific Accept-Language language identifier tags on Android 14 with regional preferences set

Categories

(GeckoView :: General, defect)

Firefox 121
All
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1847701

People

(Reporter: code, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Android 14; Mobile; rv:121.0) Gecko/121.0 Firefox/121.0

Steps to reproduce:

  1. (On Google Pixel with English US locale on Android 14.) Go to System Settings: System: Language: Regional preferences (new in Android 14).
  2. Set the first day of week to Monday and temperature to Celsius.
  3. Open Fenix and inspect the HTTP Accept-Language request header.

Actual results:

Accept-Language: en-US-u-fw-mon-mu-celsius,nb-NO-u-fw-mon-mu-celsius;q=0.5

Expected results:

Accept-Language: en-US,nb-NO;q=0.5

Summary: Unexpected Accept-Language entries on Android 14 with regional preferences set → Over-specific Accept-Language language identifier tags on Android 14 with regional preferences set

The extra language identifier may lead to websites compatibility issues and allows for more fingerprinting.

This also affects APIs like navigator.language and navigator.languages.

Component: Browser Engine → Core
Product: Fenix → GeckoView
See Also: → 1847701

The severity field is not set for this bug.
:boek, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(jboek)
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Duplicate of bug: 1847701
Flags: needinfo?(jboek)
Resolution: --- → DUPLICATE
Component: Core → General
You need to log in before you can comment on or make changes to this bug.