Closed Bug 187405 Opened 22 years ago Closed 22 years ago

MIME type handling sucks (really)

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 78106

People

(Reporter: jmd, Assigned: bugzilla)

References

()

Details

Understanding all about MIME types, UNIX mailcap files, Phoenix's prefs.js, and
other arcane things, I had one heck of a time getting a simple .wav file to play
in xmms.

There are some things--some bugs, some ommisions, some design errors--that
prevent most normal users from ever accomplishing this feat.

Here's what happened.

In the helper app dialog, the obvious was to get the sound file to play is to
click the "Open" radio, click "Choose", point it to /usr/bin/xmms, click OK,
uncheck "Always ask", and click OK. Exhasting stuff.

But only the begining. In fact, you've just screwed yourself. It turns out the
"Always ask" checkbox is dependant on the stuff hidden away inside the
"Advanced" button. But I'm jumping ahead.

What you have now, is a browser that automatically downloads any wave file you
click in, instead of play it, as you told it to. Worse, it's stuck like that.
There's no helper app editor in the perferances.

So I bookmarked all of my open tabs, closed mozilla, hacked out the wave setting
from my prefs.js, and restarted.

Loaded the page again, clicked on a wave again.

Now I had to start poking around. Click the "Advanced" button. See a repeat of
the "Choose" button. OK, tell it /usr/bin/xmms again. Click OK.

I click on the "Advanced" button again. I get back COMPLETELY DIFFERENT DIALOG
BACK than the one you get the first time. Bad. BAD.

So I uncheck "ask me" in the second dialog, and return to the main helper dialog
window. Now there's a new radio, that says "Open with xmms", which is selected,
but OK is greyed out. I reselect what's already selected, uncheck the OTHER "ask
me" box in THIS dialog, and click OK.

There. Done.

Simple!

(do something!)

*** This bug has been marked as a duplicate of 78106 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.