Closed Bug 1874445 Opened 5 months ago Closed 5 months ago

Enable Early Hints Preload

Categories

(Core :: Networking: HTTP, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
123 Branch
Tracking Status
relnote-firefox --- 123+
firefox123 --- fixed

People

(Reporter: manuel, Assigned: manuel)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [necko-triaged])

Attachments

(2 files)

I do see positive results with the Early Hints Preload experiment. Ran from Firefox 121. We are now confident in our implementation. The decision is to move forward with these positive findings and enable Early Hints in release.

first_contentful_paint

Negative percentages are good for Early Hints.

percentile relative time difference absolute time difference
0.01 -2.60% 3.99ms faster
0.05 -4.32% 10.98ms faster
0.25 -3.69% 19.66ms faster
0.5 -3.73% 33.50ms faster
0.75 -2.41% 36.98ms faster
0.95 -1.04% 34.62ms faster
0.99 -1.73% 115.77ms faster
average -3.16% 30.19ms faster
min : 0.01 -2.60% 3.99ms faster
max : 0.99 -1.73% 115.77ms faster

page_load_time

Negative percentages are good for Early Hints.

percentile load time difference absolute time difference
0.01 -3.49% 8.63ms faster
0.05 -2.43% 10.59ms faster
0.25 -1.57% 15.03ms faster
0.5 -1.57% 27.79ms faster
0.75 -1.25% 40.07ms faster
0.95 -1.12% 100.61ms faster
0.99 -1.76% 452.91ms faster
average -1.53% 35.54ms faster
min: 0.02 -2.66% 8.29ms faster
max: 0.99 -1.76% 452.91ms faster

Overall no regressions, just improvements.

See Also: → 1858712
Pushed by mbucher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43598f45eee9
Enable Early Hints preload r=necko-reviewers,valentin
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 123 Branch

(Enabling a feature for release should be marked as an enhancement, not a task)
Manuel, this looks like something that should be added to our 123 release notes, could you please nominate it in Bugzilla?
https://wiki.mozilla.org/Release_Management/Release_Notes_Nomination
Thanks

Type: task → enhancement
Flags: needinfo?(manuel)

Release Note Request (optional, but appreciated)
[Why is this notable]: Early Hints is a performance feature that improves page load performance. With this change we support rel=preload and rel=modulepreload thanks to volunteer contributor zqianem. See also the notes from Early Hints rel=preconnect.
[Affects Firefox for Android]: Yes
[Suggested wording]: By enabling Preload and Modulepreload support, Early Hints are now fully supported.
[Links (documentation, blog post, etc)]:

Flags: needinfo?(manuel)
relnote-firefox: --- → ?

Thanks, note added to 123 nightly release notes with a link to MDN.

See Also: → 1875268

FF123 MDN docs work for this can be tracked in https://github.com/mdn/content/issues/31889. Mostly compatibility data update and MDN release note.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: