Mail freezes on 'send' - CPU goes to 99%, memory usage climbs indefinitely.

RESOLVED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Bill Kuhns, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Had to revert - was using Windows 1.3a release

1.3a hangs on 'send' mail. Message was small, HTML formatting, multiple
recipients (about 4). Problem was repeatable.  I reverted to 1.2.1 and problem
went away. Inbox has 700 +/- messages.

Reproducible: Always

Steps to Reproduce:
1. 'Reply All' to message which had multiple recipients.
2. Select part of original message and copy with ctl-c.
3. Click on compose window and select 'Paste as quotation'
4. Add a line of typed message content
5. Click 'Send'

Actual Results:  
All mozilla windows stopped responding and stopped repainting. CPU utilization
for mozilla.exe goes to 99%, memory utilized by mozilla.exe climbs indefinitely
(past 250mb before I killed it).

Expected Results:  
Actually sending message would have been preferable.

Win2k, latest service packs, 2.4gHz P4, 512mb RAM, IMAP server, multiple email
accounts.
Reporter:
Can you please delete the file "xul.mfl" and try it again ?
(Reporter)

Comment 2

16 years ago
I'm afraid I can'tdelete the file "xul.mfl" and try it again. I had to revert to
1.2.1 in order to get some work done. When I went back to 1.3a, I couldn't
reproduce the error - it works fine as far as I can tell. I'm reluctant to do
the exact same steps since it would result in sending redundant email to several
associates. I did try to replicate the problem with dummy recipients to no
avail. Is there any specific element of what I was doing that you think might be
critical to causing the error? I'd be glad to try anything that might help. In
the mean time, I'm back at 1.3a and I'll watch for this problem.

the "xul.mfl" hang is a known problem.
I mark this now wfm, please reopen if you see this again and can't solve it by
deleting xul.mfl
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
I was experiencing this issue on 1.3a/WinXP, managed to fix by renaming XUL.mfl
to XUL.mfl.bak
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.