Closed Bug 1874957 Opened 6 months ago Closed 5 months ago

Add a shouldLog function to console instances created by console.createInstance

Categories

(Core :: DOM: Core & HTML, task)

task

Tracking

()

RESOLVED FIXED
124 Branch
Tracking Status
firefox124 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The current Console.sys.mjs has a shouldLog(level) function that allows code to check if a message should be logged or not.

This allows for situations where code wants to know if to log or not, or if there's a case where we want to avoid unnecessary work for a log message.

Having an equivalent available on ConsoleInstance would allow us to move more code across to it.

Assignee: nobody → standard8
Status: NEW → ASSIGNED
Duplicate of this bug: 1862989
Blocks: 1862992
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc082de0e841
Add a shouldLog function to ConsoleInstance. r=dom-core,webidl,saschanaz,peterv

Issue is in bug 1876589

Flags: needinfo?(standard8)
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d2e01b74440f
Add a shouldLog function to ConsoleInstance. r=dom-core,webidl,saschanaz,peterv
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: