[DOGFOOD][FEATURE] prefill compose when a newsgroup is selected.

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

if the user has newsgroup selected in the folderpane, prefill the compose window
for news.

select "Newsgroup:" (instead of "To:") in the picker and
put the news url in the value area. (like
news://news.mozilla.org/netscape.public.mozilla.mail-news)

Comment 1

19 years ago
I think just the group name would do :-)

Comment 2

19 years ago
*** Bug 18865 has been marked as a duplicate of this bug. ***
*** Bug 20130 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Summary: [FEATURE] prefile compose when a newsgroup is selected. → [FEATURE] prefill compose when a newsgroup is selected.
Target Milestone: M13
fixing summary.  marking m13.  accepting.
Summary: [FEATURE] prefill compose when a newsgroup is selected. → [DOGFOOD][FEATURE] prefill compose when a newsgroup is selected.
I think this is dogfood, but I'm sure I'll get a pdt-

if I'm reading news, and I hit new message, we should be assuming I'm about to
post to the newsgroup I am reading, like 4.x does.

Updated

18 years ago
Whiteboard: [PDT-]

Comment 6

18 years ago
Putting on the PDT- radar.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 8

18 years ago
changing qa assigned to pmock@netscape.com
something that putterman pointed out, that will probably become it's own bug:

in 4.x, when we'd prefill compose, you'd just get the newsgroup name
in 5.0, when we prefill compose, you get a full uri.

like,

news://news.mozilla.org/netscape.public.mozilla.mail-news
news://sspitzer@news/mcom.linux

I'm ok with that, since it lets the user know explictly where they are about to
post to, but having just the newsgroup name will work, now that the code for
finding the server based on the newsgroup name is working.

comments?

Comment 10

18 years ago
Yes. I notice this.
I also heard from Laurel said that the full URL can be used here.
For my opinion....from UI, I will prefer 4.x the way it was.
laurel is right, the full uri will work.

Comment 12

18 years ago
I think it's ok if the full URI works, but I think it's *way* too much syntax to
show the user all the time. I think we have to prefill with only the group name.

Comment 13

18 years ago
I logged bug 23249 and like to move this discussion to its own bug.

http://bugzilla.mozilla.org/show_bug.cgi?id=23249

Comment 14

18 years ago
Good call, Peter.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 15

18 years ago
Verified as fixed on win32, linux, and macos using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-01-05-16-M13/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/2000-01-06-08-
M13/mozilla-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-06-11-M13/mozilla
-mac-M13.sea.bin

I tested using the html mail editor and plain text mail editor.  I verified that
when you start a new message, the netscape full uri is automaticlly in the
address field and the address type is set to 'newsgroup'.
 example:
  news://news.mozilla.org/netscape.test

Updated

18 years ago
Status: VERIFIED → REOPENED

Updated

18 years ago
Resolution: FIXED → ---

Comment 16

18 years ago
Reopen this bug for Linux platform by using 2000-01-18-08-M13 commercial build:
Prefill compose is not working for today's commercial build when a newsgroup is
selected.
I think there are problems with message compose today, you may want to wait
until the respin.

Comment 18

18 years ago
Yes. You are right!! There was bug#24228 opened for Mail/News compose messages'
problems.
Yes, MsgCompose is totaly broken this morning. Nothing is initialized!!
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
I pulled brade's check in, and this works again.  marking worksforme.
when the respins come out, you find it to be working.

Comment 21

18 years ago
Works ok for me using:
2000-02-24-08 commercial build NT 4.0
2000-02-24-08 commercial build mac OS 9.0
2000-02-24-09 commercial build linux rh6.0

Since Peter is on sabbatical, I'll mark verified for him.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.