DIV with scrollbars and height specified does not display inside a FORM

RESOLVED DUPLICATE of bug 183241

Status

()

RESOLVED DUPLICATE of bug 183241
16 years ago
16 years ago

People

(Reporter: bobbymcr, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

If the DIV tag appears inside a form with the style declaration "height: __%;
overflow: scroll;", all content inside the DIV will not be displayed.  This
seems to be the only 'bad' combination (each individual style declaration works).

Reproducible: Always

Steps to Reproduce:
See the above HTML doc.
Actual Results:  
Text displayed:
This is
wrong

Expected Results:  
Text displayed:
This is
NOT
wrong
Well, the 'height' should be interpreted as 'auto' (see the definition of
'height' in CSS2, specifically the note on percentage heights on elements whose
containing block doesn't have fixed height).  However, that doesn't seem to be
what's happening.
Duplicate of bug 183241, I think.

*** This bug has been marked as a duplicate of 183241 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.