Closed Bug 1875229 Opened 3 months ago Closed 2 months ago

Add support for extensions not allowed in private windows

Categories

(Fenix :: WebExtensions, enhancement, P2)

Firefox 121
All
Android
enhancement

Tracking

(firefox124 verified)

RESOLVED FIXED
124 Branch
Tracking Status
firefox124 --- verified

People

(Reporter: Tom25519, Assigned: willdurand)

References

Details

(Whiteboard: [addons-jira])

Attachments

(3 files)

Steps to reproduce:

  1. Install extension "Essential Buttons Toolbar" https://addons.mozilla.org/zh-CN/android/addon/essential-buttons-toolbar/
  2. Check "Allow in private browsing", touch "OK, got it"
  3. Enter add-on manager->Essential Buttons Toolbar

Actual results:

"Run in private browsing" is still disabled, if you enable it, it will still keeping after you re-enter.

Expected results:

This bug shouldn't appear.

Component: General → WebExtensions

So the bug should be

When add-on set "incognito": "not_allowed" in manifest.json

  1. don't show the dialog asking user if enable it in private mode when installing
  2. in add-ons detail page, don't show switch for "running in the private mode" or make it unclickable.

Ref: https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/manifest.json/incognito

I think it would better to notice user that this extension couldn't run in private mode due to itself limitation.

The severity field is not set for this bug.
:zmckenney, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(zmckenney)

I agree, I am going to re-purpose this bug a tiny bit.

Severity: -- → N/A
Type: defect → enhancement
Priority: -- → P2
Summary: Extension "Essential Buttons Toolbar" couldn't enable it to run in private browsing → Add support for extensions not allowed in private windows
Whiteboard: [addons-jira]
Flags: needinfo?(zmckenney)
Keywords: leave-open
Assignee: nobody → wdurand
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a5d935fdedd6
Expose `incognito` add-on property to the embedder. r=amejiamarmol,geckoview-reviewers,zmckenney
Keywords: leave-open
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch
Flags: qe-verify+

For QA, please also verify with all kind of combinations of enabled/disabled states (with re-entering the detail view by first going back to the list and the to the add-on again). For an add-on like the one mentioned in Comment 0, we should never see "Run in private ..." in the detail view.

Verified as fixed on the latest Nightly with 124.0a1 from 15.02.2024 with Motorola G9 plus (Android 11) and OnePlus A3000 (Android 6).

Flags: qe-verify+
Attached video Add-on.mp4

:willdurand is there anything here you would like to mention in the 124 release notes?

Flags: needinfo?(wdurand)

No, I don't think we need relnotes here.

Flags: needinfo?(wdurand)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: