Arrow keys fail to select a choice within a dialog box.

VERIFIED DUPLICATE of bug 84308

Status

()

Core
Keyboard: Navigation
--
minor
VERIFIED DUPLICATE of bug 84308
15 years ago
15 years ago

People

(Reporter: Lawrence Worth, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

When I enter information on a site, for example, to purchase a product, Mozilla
always asks whether I'd like to remember the fields I filled in.  The choices
are "Yes" (default), "Never for this site", and "No".  The arrow keys won't
navigate, which makes the interface awkward, since it requires switching from
keyboard to mouse control.  Incidentally, the default should probably be "No",
since otherwise it's easy to accidentally hit Enter, which would potentially
save sensitive information such as a credit card number on the harddisk in an
unencrypted format,  with no easy way to overwrite (as opposed to merely delete) it.

I seem to think that other, if not all, Mozilla dialog boxes disallow keyboard
navigation.



Reproducible: Always

Steps to Reproduce:
1. Go to a site with an encrypted form.
2. Fill out the form.  Get the dialog box mentioned above.
3. Try to choose "No" with the arrow keys.


Actual Results:  
Nothing.  That's the point.

Expected Results:  
Moved the marquee from one choice to another.
(Assignee)

Comment 1

15 years ago
Works for me. I guess it didn't make it into 1.2.1. You'll have to wait for 1.3
or use a nightly build.

Thanks for the bug report - if you can, try to test a recent nightly trunk build
when reporting bugs. Thanks.

*** This bug has been marked as a duplicate of 84308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.