Closed Bug 1875273 Opened 6 months ago Closed 6 months ago

Perma TEST-UNEXPECTED-FAIL | layout/style/test/test_dynamic_change_causing_reflow.html | Changing style from 'content-visibility: visible' to 'content-visibility: hidden' on DIV should cause frame construction when Gecko 123 merges to Beta on 2024-01-22

Categories

(Core :: CSS Parsing and Computation, defect)

defect

Tracking

()

VERIFIED FIXED
123 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox121 --- unaffected
firefox122 --- unaffected
firefox123 + verified

People

(Reporter: noemi_erli, Assigned: fredw)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central-as-beta simulation:
How to run these simulations:
Failure log

[task 2024-01-18T12:05:08.634Z] 12:05:08     INFO - TEST-UNEXPECTED-FAIL | layout/style/test/test_dynamic_change_causing_reflow.html | Changing style from 'content-visibility: visible' to 'content-visibility: hidden' on DIV should cause frame construction - didn't expect 943, but got it
[task 2024-01-18T12:05:08.634Z] 12:05:08     INFO -     SimpleTest.isnot@SimpleTest/SimpleTest.js:528:14
[task 2024-01-18T12:05:08.634Z] 12:05:08     INFO -     checkFinalCount@layout/style/test/test_dynamic_change_causing_reflow.html:952:14
[task 2024-01-18T12:05:08.634Z] 12:05:08     INFO -     runOneTest@layout/style/test/test_dynamic_change_causing_reflow.html:993:18
[task 2024-01-18T12:05:08.634Z] 12:05:08     INFO -     @layout/style/test/test_dynamic_change_causing_reflow.html:1010:12
[task 2024-01-18T12:05:08.634Z] 12:05:08     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(fwang)

Thanks, I think that's expected until bug 1874874 enables layout.css.content-visibility.enabled by default. For now, I'll try uploading a patch that forces the mochitest to run with that flag on.

Flags: needinfo?(fwang)

:emilio, since you are the author of the regressor, bug 1765615, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(emilio)
Assignee: nobody → fwang
Flags: needinfo?(emilio)

The tests added in bug change assumes that content-visibility is
enabled but that's currently only the case in nightly, so new failures
appear when Gecko 123 merges to Beta. This is fixed by making the test
expectations depend on whether content-visibility is enabled.

Pushed by fwang@igalia.com:
https://hg.mozilla.org/integration/autoland/rev/0305ebe00639
Make test_dynamic_change_causing_reflow.html work when content-visibility pref is disabled. r=layout-reviewers,emilio
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 123 Branch
Flags: needinfo?(nerli)

Verified fixed in today's beta-sim

Status: RESOLVED → VERIFIED
Flags: needinfo?(nerli)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: