Closed Bug 187566 Opened 22 years ago Closed 22 years ago

Upgrade section is unclear (missing -dP in suggested cvs command)

Categories

(Bugzilla :: Documentation, defect, P2)

x86
Linux

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: jnerad, Assigned: jacob)

References

()

Details

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

When I performed cvs -z3 upgrade on my bugzilla directory, the upgrade failed
with this error in the error_log:

No value for param requirelogin at Bugzilla/Config.pm line 135.

for any script.

I next ran checkconfig.pl to see if that would fix the problem.  I made
progress, and got this error (which isn't logged... that is another bug, IMO)

Template->process() failed twice.
First error: undef error - Template::Exception at
/usr/local/lib/perl5/5.6.1/CGI/Carp.pm line 301.
Second error: undef error - Template::Exception at
/usr/local/lib/perl5/5.6.1/CGI/Carp.pm line 301.

The solution appears to be to upgrade using the -d switch:

cvs -z3 upgrade -d






Reproducible: Didn't try

Steps to Reproduce:
1. Get a running installation of bugzilla 2.17.1
2. Upgrade following directions in section 5.9 of the documentation
3. Run checkconfig.pl (a step also missing from the documentation)
4. run cvs -z3 update -d 

Actual Results:  
Everything worked groovy.

Expected Results:  
hmm..

This is a trivial fix.  And could be performed in a snap, but could be quite
frustrating to an inexperienced bugzilla admin.
Attached patch docs/html/upgrading.html patch (obsolete) — Splinter Review
This would fix the upgrading docs.
This would fix the text version of the documentation
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: section 5.9 needs revision → 2.17.1 -> 2.17.3 cvs upgrade fails
I guess this one is the one you need to make, as it is the sgml patch.	Sigh.
Ok... I tested this on landfill; bug was experienced as reported.

As reported, running cvs up with -d and ./checksetup.pl again fixed it.

Looks like the guilty directories/files are:
U Bugzilla/Template/Plugin/Bugzilla.pm
U template/en/default/admin/products/groupcontrol/confirm-edit.html.tmpl
U template/en/default/admin/products/groupcontrol/edit.html.tmpl
Status: NEW → ASSIGNED
The cvs upgrade instructions at http://www.bugzilla.org/download.html are correct.
I didn't realize we had a copy of those instructions in the documentation as well.
I would personally recommend using "cvs -z3 update -dP" since there are several
directories in the tree which don't belong for one reason or another, and the -P
portion will remove those directories from your local tree as well.
And you should ALWAYS run checksetup.pl after a cvs update.  ALWAYS ALWAYS. :-)

If that's missing it definitely needs to be fixed.
Comment on attachment 110587 [details] [diff] [review]
docs/sgml/adminstration.sgml patch

use "-dP" instead of "-d".

And it needs to better state that "you MUST run checksetup.pl" after doing a
cvs update.  It's a mandatory thing, there's no "may" about it.
Attachment #110587 - Flags: review-
Attachment #110584 - Attachment is obsolete: true
justdave: even though the instructions on bugzilla.org are correct, think we
should fix this and post a quick note to n.p.m.w?

I guess people actually read our documentation... imagine that... ;-)
Attachment #110586 - Attachment is obsolete: true
well, duh! :)  of course we fix the documentation.

I didn't say we don't care about the docs because it's on the website, I was
just offering a comparison. :)

The mandatoriness of running checksetup.pl wasn't stated on the website
(although the -dP thing was), I just fixed that on the website, should be live
in another 5 minutes or so.
Right, right, right... (I'm still drinking my morning cup of coffee)... I was
more asking about posting to the newsgroup.

Maybe that was in there because I was silently wondering if we would rebuild the
docs--something we usually only do at release timees--because of this.
The docs get rebuilt periodically anyway, not just at release.  Especially if we
have important changes like this since the html docs from the tip are put on the
website.
Jake or Barnboy, can we get this fixed up and put in?
This patch is an attempt to make the entire section clearer and to talk about
different methods of updating (CVS, tarball, and patch files).
Attachment #110587 - Attachment is obsolete: true
Jack, I do appreaciate your reporting this and providing the patch you did, but
I feel that entire section was in need of a rewrite :)
Assignee: matthew → jake
Status: ASSIGNED → NEW
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18
Jacob: My pleasure.  Bugzilla is a great piece of software.  And your patch is
way more than I hoped for.  Good stuff.
Checked in.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Summary: 2.17.1 -> 2.17.3 cvs upgrade fails → Upgrade section is unclear (missing -dP in suggested cvs command)
Jake: can you check this in (with appropriate changes to the examples if
necessary) on both the 2.14 and 2.16 branches as well?  (and regenerate the HTML
so it shows up on the website before checking in).  Thanks.
Done on the 2.16 branch.  The 2.14 branch doesn't have enough text in the
upgrading section to even contain the mistake this bug was filed about, so it's
not worth porting this fix.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: