Key entry not recognized in Page Setup in Mac OS X 10.1.x

RESOLVED DUPLICATE of bug 155558

Status

Camino Graveyard
Printing
RESOLVED DUPLICATE of bug 155558
15 years ago
14 years ago

People

(Reporter: Jesse, Assigned: Conrad Carlen (not reading bugmail))

Tracking

unspecified
Camino0.8
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030101 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030101 Chimera/0.6+

"Scale" cannot be selected (highlighted) but not changed in Page Setup. If a
text box is active in the browser (either Location box or within a web page) key
events will appear there although some may not be recognized (delete key not
recognized). If no text entry box is active, key events still not recognized in
Page Setup.

I am running OS 10.1.5 and am told this is a known issue because of the use of
Carbon print dialogs in a Cocoa app. Apparently it is resolved under 10.2 but I
would appreciate a fix for pre-10.2. It DID work in the official 0.6 release of
Chimera. I do not know at what point it ceased working though I tested the
12/24, 12/30 and 01/01/03 builds all of which failed to recognize the key events.

Reproducible: Always

Steps to Reproduce:
1. Select Page Setup at any point in your session (even on a blank startup page)
2. Attempt to change "Scale"
Actual Results:  
Unable to alter "Scale".

Expected Results:  
"Scale" should change according to typed input.

Comment 1

15 years ago
WorksForMe using Chimera/2003021707. Jesse, can you still reproduce this problem
using a current nightly build?
(Reporter)

Comment 2

15 years ago
It still does not work for me on build 2003020707. I doubt it has been fixed in
the last week and a half. Again, my understanding is it works in 10.2.x but not
10.1.x. What OS version are you using?

Comment 3

15 years ago
Mac OS X 10.2.4.
Whiteboard: Mac OS X 10.1.x only

Updated

15 years ago
Summary: Key entry not recognized in Page Setup → Key entry not recognized in Page Setup in Mac OS X 10.1.x
Whiteboard: Mac OS X 10.1.x only

Comment 4

15 years ago
Since 0.6 was built on 2002-11-04, try nightlies between that and the 2002-12-24
you already tried. If you can isolate when it happened, that would make
diagnosing the problem much easier. (I can't promise you it will be fixed, though.)
(Reporter)

Comment 5

15 years ago
From where can I access nightlies other than the latest? It will take me some
time to pinpoint the offending nightly as I am on a dial up modem. The best I
can do is test a nightly halfway between your suggested dates, and halfway
between the nightly I choose and the november nightly, etc. until I find the change.

Comment 6

15 years ago
Oops, looks like the nightlies only go back to 2003-01-24 at
<ftp://ftp.mozilla.org/pub/chimera/>. Try asking on the newsgroup or at the web
forums if anyone has older builds.

Comment 7

15 years ago
Oh, there does appear to be a 2002-12-20 build you cou test. Try that.

Comment 8

15 years ago
I can confirm the issue with 2003070804 on OS 10.1.5. If no text box is active
in the browser, find as you type is activated.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

14 years ago
Since we are going to drop 10.1 support after 0.8 this should be fixed before.
Target Milestone: --- → Camino0.8
does this still happen with nightly builds?
(Assignee)

Comment 11

14 years ago

*** This bug has been marked as a duplicate of 155558 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.