Up/Down keys on a INPUT with several lines in it don't move cursor

RESOLVED DUPLICATE of bug 77932

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED DUPLICATE of bug 77932
16 years ago
4 years ago

People

(Reporter: Daniel Clemente, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
1. Copy this text (the two lines):
first line
second line
   2. Go to a page with an INPUT, eg. http://www.google.com
   3. Paste the text on the INPUT. You see "second line". Move around the text
with Left/Right keys. All ok; it goes through the line break in the middle.

   4. Place the cursor at the end of "second line". Then, press Up key.

   You see "first line", but the cursor doesn't go there; if you press Home or
End, the cursor will jump to the start or the end of the 2nd line.


   I don't know if this the intended behaviour, but if you want to go to the
start of "first line", you have to press Left a lot of times. Pressing Up and
then Home should do it.
the real bug is that we don't strip out the linefeeds on paste there...
Whiteboard: DUPEME

Comment 2

16 years ago
bug 77932?
yeah

*** This bug has been marked as a duplicate of 77932 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.