Closed Bug 1878277 Opened 3 months ago Closed 2 months ago

Prior search settings are not kept when using amazon.es or amazon.se as default search engine

Categories

(Firefox :: Search, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
124 Branch
Tracking Status
firefox124 --- verified

People

(Reporter: cbaica, Assigned: mcheang)

References

(Blocks 1 open bug)

Details

(Whiteboard: [sng])

Attachments

(2 files)

Found in

  • Fx124.0a1

Affected versions

  • Fx 124.0a1

Affected platforms

  • Windows
  • Ubuntu
  • macOS

Preconditions
Download an es-ES locale build.
Set browser.search.region to ES.

Steps to reproduce

  1. Launch Firefox
  2. Set Amazon.es as default search engine.
  3. Go to about:config and switch to the new search config (set browser.search.newSearchConfig.enabled as true).
  4. Restart the browser.

Expected result

  • No info banner about the default engine is received.
  • Default search engine is still Amazon.es

Actual result

  • Info banner is received.
  • Google is set as default search engine.

Regression range

  • This is not a regression.

Additional notes

  • Please note that when other regions are used, that also have amazon, like IT, US, GB (amazon.it, amazon.com, amazon.co.uk), amazon remains the default search engine after the config change and no info banner is received.
  • Issue seems to only be with amazon.es, because it happens whenever that particular localization of amazon causes trouble. For example if I use the es-ES locale, have the region set to PT and have amazon set as default engine, the issue reproduces again.
  • Later investigation uncovered that the issue is also happening for amazon.se as well. (locale: sv-SE, region: SE).
Summary: Prior search settings are not kept when using amazon.es as default search engine → Prior search settings are not kept when using amazon.es or amazon.se as default search engine

:cbaica, if you think that's a regression, could you try to find a regression range using for example mozregression?

Assignee: nobody → mcheang
Severity: normal → S3
Priority: -- → P2
Whiteboard: [sng]
Pushed by mcheang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/546580b659fb
Add id mapping for amazon-es and amazon-se to amazon-spain and amazon-sweden so that the prior search settings persist. r=Standard8
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch

Marking the issue as verified fixed using the latest Fx 124.0a1 and the new search config. Amazon remains as default engine after switching to search config v2.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: