CSS not parsing properly?

RESOLVED DUPLICATE of bug 185498

Status

()

Core
XSLT
RESOLVED DUPLICATE of bug 185498
16 years ago
16 years ago

People

(Reporter: Joseph Elwell, Assigned: peterv)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This bug needs a simplified test case.

Steps to reproduce:
1) Load URL
2) hit Ok button which should take an xml datasource and transform it using an
xsl style sheet.

Actual results:
Text with no style.

Expected results:
Text with nice pretty boxes and pictures and some style!

This demo works on Netscape 7.01, Mozilla 1.1, Internet Explorer 6+, but is
broken on Mozilla 1.2, Mozilla 1.3a, phoenix .5, and chimera recent trunk
nightly as well as today's Mozilla trunk build from Jan 6, 2003.

It seems sometime between Mozilla 1.1 and Mozilla 1.2 this broke on the trunk,
however those builds aren't available anymore so I can't really narrow this down.
->XSLT, for triage anyway
Assignee: block-and-inline → peterv
Component: Layout: Block & Inline → XSLT
QA Contact: ian → keith
I suspect this is because of bug 185498, however the testcase is a bit too big
to tell by just looking at it. I'll try to run the page once we have have a
patch for that bug.


I also noticed something else that you'll have trouble with, that is a bug in
the mozilla DOM implementation (*not* a bug in the XSLT engine). Mozilla will
not be able to handle the following:

<img border="0" width="52">
 <xsl:attribute name="src">images/<xsl:value-of select="photo"/></xsl:attribute>
</img>

change it to

<img border="0" width="52" src="images/{photo}/>

That should work in mozilla as well as IE. Same with

<img>
 <xsl:attribute name="src">
  <xsl:value-of select="rating/joerating"/>
 </xsl:attribute>
</img>

is more safly done with:

<img src="{rating/joerating}"/>
Depends on: 185498
(Reporter)

Comment 3

16 years ago
Jonas, thanks for the tips. Although Mozilla has worked just fine with those img
src rules before. If I recall correctly I originally tried to put the attribute
directly into the img tag but it didn't work.

Comment 4

16 years ago
jonas is right, this is indeed a problem with the outputdoc not being an
htmldoc.
Note that I don't think that having myroot as an html element is a wise move,
a div would do just as fine

*** This bug has been marked as a duplicate of 185498 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.