Bookmarked tab groups close open tabs

VERIFIED DUPLICATE of bug 167188

Status

--
minor
VERIFIED DUPLICATE of bug 167188
16 years ago
16 years ago

People

(Reporter: catfish.man, Assigned: sfraser_bugs)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030101 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030101 Chimera/0.6+

I have a set of 5 tabs that I use frequently bookmarked. Recently I opened two
tabs, then opened the bookmark expecting to have 5 more tabs added. Instead, the
two tabs I had open were replaced with two of the bookmarked ones, so that I had
to manually reopen the original two pages. I realize this is normal behavior
with single page bookmarks, but replacing multiple tabs seems like the wrong
behavior to me.

Reproducible: Always

Steps to Reproduce:
1.Bookmark a group of tabs
2.Open any number of tabs
3.Click on the bookmark

Actual Results:  
The open tabs were replaced by the bookmarked ones.

Expected Results:  
Opened new tabs for the bookmark.

Comment 1

16 years ago
I understand David but if his solution is used this will lead to confusion.
What to do if there is one page opened and call a 5-tabs bookmark?
Put it as the first tab and add the 5 other tabs ?

For consistency, I suggest treating multiple-tabs bookmarks (MTB) like any other
bookmark.
To offer a consistent solution to the problem described by David,
I suggest following Bug 155863 rules:

Click a MTB : the MTB replace window's content, overidding existing page or
existing tabs from the first one. If the MTB contains less tabs than the current
page, the remaining tabs on the page are unchanged, not deleted.

Opt-Click a MTB : add the MTB after the page contents, which if it's not empty
becomes the first tab, or after the existing tabs.

Cmd-Click a MTB : open a new window with all the MTB tabs.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Yes this behaviour is also driving me nuts as it does not match Mozilla's
"de-facto" standard for tab-group bookmarks.

> I understand David but if his solution is used this will lead to confusion.
> What to do if there is one page opened and call a 5-tabs bookmark?
> Put it as the first tab and add the 5 other tabs ?

Yes! This is exactly what Mozilla does now. Let me show you why doing this makes
sense. My daily routine every morning when I get into work is to fire up Mozilla
(which is my primary browser until this is fixed in Chimera). My home page is
slashdot.org. So I start up Mozilla and as slashdot.org is loading I go to my
bookmarks menu and click on my "Netcraft Uptimes" tab-group bookmark group. This
leaves slashdot as my first tab and then opens 6 more tabs for each server
uptime page. Note that slashdot is left as the displayed tab because I have the
load new tabs in the background preference checked. Then I click on my "News
Sites" tab-group bookmark. This then loads the tabs of the 8 news sites I read
after my netcraft tabs. Slashdot is still my currently selected tab. By now,
Slashdot is fully loaded and I can go ahead reading it. If there are any
articles I want to read I then open those in new tabs which are added after my
news tabs and load in the background, leaving me still on slashdot. Once I'm
done with slashdot I close the tab and then quickly look through the netcraft
tabs closing them as I go. Now on to the news site tabs opening links as new
tabs as I go. I just keep moving down the line until I've read everything I want.

Now you may be asking, why not just have one tab-group bookmark that has
slashdot, netcraft tabs, and news tabs in it. Because I don't want to. I read
slashdot at least 4 or 5 times a day which is why I made it my home page. If I'm
opening a new browser window (instead of a tab), 90% of the time is because I
want to read slashdot. Since slashdot is already loaded as the home page,
including it in a tab-group bookmark would cause it to be needlessly loaded a
second time as part of the bookmarks loading. Now I only want to check netcraft
once a day but the other news sites a couple times a day which is why they are
separate bookmarks. So combining those together would cause the extra loading to
not only waste bandwidth but my time as well because of the extra delay in
loading and the fact that I would have to keep closing them.

I have been doing this routine every day for several months since whenever tab
group bookmarks were added to Mozilla?

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 167188 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.