thingamajob.com - Submit button on this page does nothing. Works fine in IE 5.5

RESOLVED DUPLICATE of bug 192170

Status

RESOLVED DUPLICATE of bug 192170
16 years ago
3 years ago

People

(Reporter: hisstg, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021212

Entered a keyword to search for on this page, and clicked on the Search button.
 Nothing happened.  The source code shows that the button should start a
validation, but nothing seems to happen.

The button code on the page is:
<!--
window.document.SearchForm.CRITERIA.focus();
//-->
</script>
      <tr>
        <td align="right" class="bodytext">Post Date:</td>
        <td class="bodytext">
          <select name="TIME_FRAME">

		<option value=1>All</option><option value=2>Today</option><option value=3>< 1
Week Old</option><option value=4>< 2 Weeks Old</option><option value=5>< 3 Weeks
Old</option><option value=6>> 3 Weeks Old</option>
          </select>
        </td>
      </tr>
      <tr>
	  <td align="right" valign="top">&nbsp;&nbsp;</td>

        <td align="left">
          <input type="submit" name="Search" value="Search"
onClick="validatetimeframe(this.form)">
          <input type="button" name="Clear" value="Clear"
onClick="clearForm(this.form);">
        </td>
      </tr>
    </table>
    </center>
    </form>
  <script LANGUAGE="JavaScript">

function validatetimeframe(theForm2)
{

  if ((trim(theForm2.SEARCHPOSTID.value) != "" &&
theForm2.TIME_FRAME.selectedIndex != 0))
	{

		alert ("A Job Posting ID can not be combined with other search criteria. 
Please redefine your search.");
		return false;
	}
	return validate(theForm2);
}



</SCRIPT>

Reproducible: Always

Steps to Reproduce:
1. Navigate to page
2. Enter a word in the keyword field - such as Lotus
3. Click on Search button

Actual Results:  
No change to any visible part of screen.

Expected Results:  
Brought up a new page showing one or more results.

Plain vanilla mozilla.  Only change from complete installation of download is
import of IE Favorites.

Comment 1

16 years ago
Tech Evangelism case. Form described as:

<form name="SearchForm" onSubmit="return false;" method=post
action="/NASApp/jobengine/JobSearchResults?src=-1">

Mozilla first use onsubmit -- and "return false" mean that submit was
unsuccesfull , action do not run. IE doing another: it first use action, and
only then onsubmit (wich do not used, because page changes). So behaviour of
Mozilla pretended to be nihill.

-> TE (page code error)
Assignee: asa → susiew
Status: UNCONFIRMED → NEW
Component: Browser-General → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: asa → zach
Version: Trunk → unspecified

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: Submit button on this page does nothing. Works fine in IE 5.5 → thingamajob.com - Submit button on this page does nothing. Works fine in IE 5.5

Comment 4

15 years ago
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

This is not TE, but rather a duplicate of bug 192170

Comment 5

15 years ago
Form wfm with 1.5 and should since 1.4.

*** This bug has been marked as a duplicate of 192170 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.