Closed Bug 1881802 Opened 5 months ago Closed 5 months ago

[Caret browsing] Highlighting doesn't work when pressing shift and arrow down

Categories

(Firefox :: PDF Viewer, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr115 --- disabled
firefox123 --- disabled
firefox124 --- verified
firefox125 --- verified

People

(Reporter: calixte, Assigned: calixte)

References

Details

Attachments

(1 file)

Attach (recommended) or Link to PDF file here:

Steps to reproduce the problem:

  1. Enable caret browsing mode;
  2. Open a pdf with some text;
  3. Enable highlighting tool;
  4. Position the caret on some text;
  5. Press shift and the arrow down, release shift.

What is the expected behavior? (add screenshot)
The text must be highlighted.

What went wrong? (add screenshot)
Nothing is highlighted.

In caret browsing mode, pdf.js is handling the selection itself, which means that no selectstart is triggered.

Blocks: 1846098
Duplicate of this bug: 1881707
No longer depends on: 1882694
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Depends on: 1883010
No longer depends on: 1883010

Verified as fixed in our latest Nightly build 125.0a1 (2024-03-01) ID 20240301094944.

This issue is Verified as fixed in our latest Beta 124.0b7 because it was uplifted with Bug 1883050.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: