Closed Bug 1881979 Opened 2 months ago Closed 2 months ago

Crash reporter has mismatching ptrace types on musl

Categories

(Toolkit :: Crash Reporting, defect)

defect

Tracking

()

RESOLVED FIXED
125 Branch
Tracking Status
firefox125 --- fixed

People

(Reporter: ptrcnull, Assigned: ptrcnull)

Details

Attachments

(1 file)

When trying to compile Firefox 120.0.2 through 123 ( others not tested ) on Alpine Linux edge, the following happens:

 error[E0308]: mismatched types
    --> toolkit/crashreporter/mozannotation_server/src/process_reader/linux.rs:272:40
     |
 270 |     fn from(val: PTraceOperation) -> Self {
     |                                      ---- expected `u32` because of return type
 271 |         match val {
 272 |             PTraceOperation::Attach => PTRACE_ATTACH,
     |                                        ^^^^^^^^^^^^^ expected `u32`, found `i32`
     |
Assignee: nobody → bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3af6901e77d5
Use c_int as ptrace request type on musl libc. r=gsvelto
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: