Keyboard move/select by word (ctrl+arrow) stops too often in unicode text with punctuation

RESOLVED WORKSFORME

Status

()

Core
Selection
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

({helpwanted, intl})

Trunk
helpwanted, intl
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
[1]unicodetext[2]-[3]unicodetext [4]moretext
(Assume the bracketed numbers are markers, not actually in text).

When hitting Accel+[shift]+arrow to move or select by word it incorrectly stops
both before and after punctuation -- [2] and [3].

user_pref("layout.word_select.stop_at_punctuation", true);
Should only stop at [1], [3] and [4]

user_pref("layout.word_select.stop_at_punctuation", false);
Should only stop at [1] and [4]

Spun off from bug 98546.
(Assignee)

Comment 1

15 years ago
Created attachment 110963 [details]
Some unicode text with punctuation in the middle
(Assignee)

Comment 2

14 years ago
Does anyone even fix i18n bugs anymore?
Keywords: helpwanted
Summary: Keyboard move/select by word stops too often in unicode text → [i18n] Keyboard move/select by word stops too often in unicode text
(Assignee)

Updated

14 years ago
Whiteboard: DUPEME

Comment 3

14 years ago
Is bug 236172 a dup of this?
*** Bug 336449 has been marked as a duplicate of this bug. ***
Adding some words to the summary to allow for easier finding.
Keywords: intl
Summary: [i18n] Keyboard move/select by word stops too often in unicode text → Keyboard move/select by word (ctrl+arrow) stops too often in unicode text with punctuation

Updated

11 years ago
Blocks: 344417
Note to self (or anyone else who wants to fix this):

The issue here is that both layout.word_select.stop_at_punctuation and aIsKeyboardSelect are ignored in the "Unicode" case (when the string contains two-byte characters), that is in nsTextTransformer::ScanNormalUnicodeText_F/B.
The behavior is as if layout.word_select.stop_at_punctuation is true, and aIsKeyboardSelect is false.
Depends on: 389421
WFM with Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008022804 Minefield/3.0b4pre ID:2008022804.

Probably fixed by the new textframe (bug 367177).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.