Provide method to disable specific/all javascript in <body> tag

RESOLVED DUPLICATE of bug 64737

Status

()

Core
DOM: Events
--
enhancement
RESOLVED DUPLICATE of bug 64737
15 years ago
15 years ago

People

(Reporter: Dan Mellem, Assigned: saari (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Some sites want to really control what's shown on their site to the point of
making naviga

Some web sites use javascript to disable useful features in the browser, such as
scrollbars, the nav. bar, etc. These are ususally done by using window.open but
some things can be changed in the <body> tag. I'd like a pref to disable these
features. Some events would include oncontextmenu, ondragstart, onmouseover, and
onselectstart.

Reproducible: Always

Steps to Reproduce:
See attached example. Context menu is disabled.
(Reporter)

Comment 1

15 years ago
Created attachment 111000 [details]
oncontextmenu.html - simple web page with onContextMenu in <body>
see bug 86193

*** This bug has been marked as a duplicate of 64737 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.