Password manager should pass proxy password to Java plugin

RESOLVED DUPLICATE of bug 60304

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 60304
16 years ago
14 years ago

People

(Reporter: Kai Stukenbrock, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030107
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b) Gecko/20030107

I am sitting behind a proxy that requires authentication. Password manager takes
care of that for the browser, but whenever I go to a site that has Java for the
first time during my browsing session, the Java plugin asks me for the username
and password for the proxy server again, which I find very inconvenient. (and IE
does not exhibit this behavior)

As the browser can pass the proxy settings on to Java, I figure it should also
be possible to pass authentication on from Mozilla password manager to Java!?

Reproducible: Always

Steps to Reproduce:
1.Start Mozilla with a proxy that requires authentication
2.Authenticate with Proxy
3.Go to site that requires Java

Actual Results:  
Need to authenticate again with Java

Expected Results:  
Initial authentication should be passed on from Mozilla to Java, or, if not
possible, Moz password manager should at least fill out authentication window of
Java, so that only OK needs to be clicked...

*** This bug has been marked as a duplicate of 60304 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.