Can not open files the 8-bit accent character named file/directory on WinXP-Japanese/Chinese

RESOLVED DUPLICATE of bug 162361

Status

()

Core
Internationalization
RESOLVED DUPLICATE of bug 162361
16 years ago
13 years ago

People

(Reporter: Yuying Long, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 01-09 trunk build on WinXP-SimpChinese

Steps to reproduce:
1. Create a file/directory name on Windows file system.
E.g. I have created a file name "спc.html" under:
C:\спc.html and C:спc\спc.html
2. Launch mozilla browser, and open the file.

Result:
Can not open the file, got an error message instead (refer to the following
screen shot).

Note:
1. IE can open the file properly.
2. For N7.01(1.02 branch), non-ascii characters are escaped, the file can be opened.
(Reporter)

Comment 1

16 years ago
Created attachment 111077 [details]
screen shot for error message

Comment 2

16 years ago
Can you reproduce this in Japanese or a Latin-1 language?
(Reporter)

Comment 3

16 years ago
Here are some more results:
             WinXP-JA              WinXP-SC             WinXP-US
            Moz     IE             Moz    IE           Moz    IE
           -------------          ------------        -------------
JA file     OK      OK             OK     OK           fail   OK
CH file     fail    OK             OK     OK           fail   OK
8bit        fail    OK             fail   OK           OK     OK

Note:
1. On WinXP-US, the Japanese and Chinese directory name are showed as square,
but can be opened in IE.   
2. On Japanse and Chinese WinXP, change system locale to EN won't make any
difference.
Summary: Can not open files the 8-bit accent character named file/directory on WinXP-Chinese → Can not open files the 8-bit accent character named file/directory on WinXP-Japanese/Chinese

Comment 4

14 years ago
I am a new user of Mozilla and have just found this same bug.

I run WinXP (US) Home Edition; Version 2002; Service Pack 1 on a Sony Vaio
V505DX laptop. I use Mozilla 1.7.

When is save, or create locally, html pages and give them filenames in Japanese,
Mozilla will not open them. It doesn't matter if i double click the icon, open
Mozilla and then try File/Open, or right click on the icon and try either Open
or Open With. 

As long as the file name is in Japanese (SomeJapaneseWord.html), when i try and
open it i get the message, e.g., "The file /C:/Documents and Settings/David
Turkington/Miscellaneous/??????.html can not be found. Please check the location
and try again." Note that the Japanese file name has been converted
(incorrectly) into a string of question marks here even though the file name
still appears correctly in Japanese in the folder on my desktop.

However, i note that if i save the original html file with a file name in
English, then create a shortcut to that file, AND THEN give that shortcut the
Japanese file name that i originally wanted, Mozilla WILL open the file with no
problems. 

Lastly, as was pointed out in the original bug report, IE does not have this
problem. Even if the file name was in Japanese characters, IE would open it. Not
that this matters, but it may mean something to someone who knows how IE works.

Comment 5

13 years ago
*** Bug 294446 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
This bug sounds a lot like the one filed as bug #193358.
I'm not sure whether to mark one (which one?) as a duplicate (or dependancy) of
the other one, though. Maybe someone with more insight can clarify...

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 162361 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.