Closed Bug 1883896 Opened 3 months ago Closed 3 months ago

Remove UA styles for :is(article, aside, nav, section) h1 (Nightly only)

Categories

(Core :: Layout, defect)

defect

Tracking

()

RESOLVED FIXED
125 Branch
Tracking Status
firefox125 --- fixed

People

(Reporter: zcorpan, Assigned: zcorpan)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(1 file)

See https://github.com/whatwg/html/issues/7867

Since the affected number of pages is relatively high, there is a web compat risk with this change. See analysis at https://github.com/whatwg/html/issues/7867#issuecomment-1977647444

I think it's still worthwhile to change, since the current behavior is confusing.

We can use @media (-moz-bool-pref: "...") in the UA stylesheet. This allows us to change the pref on Nightly only first, and revert the pref on stable if needed.

Assignee: nobody → zcorpan
Status: NEW → ASSIGNED
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b75492ce9a7
Remove UA styles for h1 in article/aside/nav/section (Nightly only). r=emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/45108 for changes under testing/web-platform/tests
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch
Upstream PR merged by moz-wptsync-bot
Summary: Remove UA styles for :is(article, aside, nav, section) h1 → Remove UA styles for :is(article, aside, nav, section) h1 (Nightly only)
Blocks: 1885509

I see it enabled by default in Nightly. Good riddance! Is there a flag that would allow testing this behavior once Firefox 125 stable is released? We’re planning to mention it in the release notes as an experimental removal.

Regressions: 1886480

(In reply to Vadim Makeev from comment #6)

I see it enabled by default in Nightly. Good riddance! Is there a flag that would allow testing this behavior once Firefox 125 stable is released? We’re planning to mention it in the release notes as an experimental removal.

Yes, the pref is layout.css.h1-in-section-ua-styles.enabled.

FYI, PR for 125 release notes featuring the removal in the experimental features.

@zcorpan: looks like we've had this enabled-by-default on Nightly for 2 months now. Possibly worth considering next-steps (in followup bugs):

  1. Assuming things look good, maybe it's worth shipping this to early-beta, too, to see if we get any additional webcompat fallout? (changing the pref to @IS_NOT_EARLY_BETA_OR_EARLIER@)

  2. I think you were planning to submit a spec PR per https://github.com/whatwg/html/issues/7867#issuecomment-1999318189 ; want to be sure that's still on your radar.

  3. (and if/when the spec is updated, we should of course update WPT expectations as well, since at least https://wpt.fyi/results/html/rendering/non-replaced-elements/sections-and-headings/headings-styles.html depends on the traditional behavior right now and fails in Firefox Nightly as a result)

Flags: needinfo?(zcorpan)

(probably not a high priority, of course; I just happened to notice today when twisniewski and I were looking at some (nightly) Firefox-only WPT test failures.)

Thanks for the ping. Yes, we can expand to early beta, but first I'd like to check that other vendors are indeed onboard. Changing the wpt's should be done at the same time as the spec change is landed.

Flags: needinfo?(zcorpan)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: