Closed Bug 1883947 Opened 1 month ago Closed 1 month ago

Responses to requests are not shown in the Network panel of the browser toolbox

Categories

(DevTools :: Netmonitor, defect)

defect

Tracking

(firefox-esr115 unaffected, firefox123 unaffected, firefox124 unaffected, firefox125 fixed)

RESOLVED FIXED
125 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox123 --- unaffected
firefox124 --- unaffected
firefox125 --- fixed

People

(Reporter: standard8, Assigned: ochameau)

Details

(Keywords: regression)

Attachments

(2 files)

Thank you for helping make Firefox better. If you are reporting a defect, please complete the following:

What were you doing?

  1. Opened the browser toolbox and selected the network panel
  2. Selected multiprocess
  3. In a tab loaded various different pages

What happened?

  • The requests are shown, however responses are never shown.
  • If you click on one, then the only panel that shows anything is the stack trace.

What should have happened?

  • The requests should have been updated with the responses
  • The request inspector panel should have been filled in.

Anything else we should know?

  • Using the latest nightly on Mac (Official Mozilla & self build, with different profiles)
  • There's a lot of InvisibleToDebugger: Error { } DevToolsInfaillibleUtils.sys.mjs:22:13 messages on the console.

Actually, this seems to be affecting parent process requests as well (e.g. search suggestions in the address bar).

Summary: Responses to requests are not shown in the Network panel of the browser toolbox (multiprocess) → Responses to requests are not shown in the Network panel of the browser toolbox
Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED

Thanks for the report Mark!

Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6889d00f531d
[devtools] Fix netmonitor on the browser toolbox. r=devtools-reviewers,nchevobbe
Keywords: leave-open

Cover opening the details panel and verify that one header is displayed.

This bug has been marked as a regression. Setting status flag for Nightly to affected.

Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec25d27f83b7
[devtools] Expand netmonitor test coverage in the Browser Toolbox. r=devtools-reviewers,nchevobbe

If this is a regression, do we know how far back it goes?

Flags: needinfo?(standard8)
Keywords: leave-open
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch

(In reply to Ryan VanderMeulen [:RyanVM] from comment #9)

If this is a regression, do we know how far back it goes?

It doesn't appear to be in 123 nor 124, so probably recent.

Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: