Closed Bug 1884172 Opened 1 month ago Closed 1 month ago

Can't paste a screenshot into Slack

Categories

(Firefox :: Screenshots, defect)

x86_64
macOS
defect

Tracking

()

VERIFIED FIXED
125 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox123 --- unaffected
firefox124 --- unaffected
firefox125 + verified

People

(Reporter: overholt, Assigned: niklas, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

For a Nightly or two (I can use mozregression if it'll help), I can't paste a screenshot captured using Firefox's screenshot tool into Slack. It was pointed out to me that bug 1789727 recently landed so perhaps this is a regression from that? I'm also told this works on Windows but it doesn't work on my Mac.

Flags: needinfo?(nbaumgardner)

FWIW I can verify the screenshot content is on the clipboard.

Regressed by: 1789727

Set release status flags based on info from the regressing bug 1789727

Thanks for filing this!
I was not able to reproduce this on Windows. I don't have access to my mac right now so I'm unable to test this.
Does this happen on the slack app or site? or both?

Flags: needinfo?(nbaumgardner) → needinfo?(overholt)

(In reply to Niklas Baumgardner [:niklas] from comment #3)

Does this happen on the slack app or site? or both?

Slack.com (site) I don't have the app installed but I can if you'd like.

Flags: needinfo?(overholt)

I can also reproduce this issue on macOS 13 using the latest Nightly 125.0a1. When I try to paste a copied screenshot in slack.com (also loaded in Nightly), it does not work.

However, I'm not encountering any issues when pasting the screenshot into the Slack app or the website version using a different browser.

The issue is not reproducible using the latest Nightly 125.0a1 on Ubuntu 22.04.

I ran mozregression and ran into many builds that had tab crashes with slack.com. It looks like it started failing some time between 2024-03-04 and 2024-03-05 and mozregression pointed me specifically at bug 1847358. Tom, do you think part 3 of your work in https://phabricator.services.mozilla.com/D203380 could be responsible for the regression here?

Flags: needinfo?(twisniewski)

I doubt it, as I'm not sure why my patch would cause a difference. If I take a look at event.clipboardData.items[0] on a paste event after taking a screenshot, which Slack should be doing if I'm reading their minified code correctly, then I do see what I would expect: DataTransferItem { kind: "file", type: "image/png" }. The screenshot also looks fine when I paste it into another app, so I don't see why my code would affect it.

But I suppose we could always revert that patch and see what happens?

Flags: needinfo?(twisniewski)
Assignee: nobody → nbaumgardner
Status: NEW → ASSIGNED
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a24a00e9a529
Use x-moz-nativeimage when copying screenshots to clipboard. r=mconley
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch
Status: RESOLVED → REOPENED
Flags: needinfo?(nbaumgardner)
Resolution: FIXED → ---
Target Milestone: 125 Branch → ---

Set release status flags based on info from the regressing bug 1789727

Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1e8ffb360c27
Use x-moz-nativeimage when copying screenshots to clipboard. r=mconley

Backed out for causing OSX mochitests failures in browser_screenshots_test_visible.js

  • Backout link
  • Push with failures
  • Failure Log
  • Failure line: TEST-UNEXPECTED-FAIL | browser/components/screenshots/tests/browser/browser_screenshots_test_visible.js | R color value - 111 == 130 - {"filename":"chrome://mochitests/content/browser/browser/components/screenshots/tests/browser/browser_screenshots_test_visible.js","name":"test_visibleScreenshot/<","sourceId":882,"lineNumber":69,"columnNumber":14,"sourceLine":"","asyncCause":null,"asyncCaller":{"filename":"resource://testing-common/BrowserTestU
Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7250823eff5f
Use x-moz-nativeimage when copying screenshots to clipboard. r=mconley
Status: REOPENED → RESOLVED
Closed: 1 month ago1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 125 Branch

Verified as fixed using the latest Nightly 125.0a (Build ID: 20240314092545) on macOS 13, Ubuntu 22.04 and Windows 10 x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: