Closed Bug 1884424 Opened 2 months ago Closed 2 months ago

[css-shapes-2] Implement shape() function for offset-path

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
126 Branch
Tracking Status
relnote-firefox --- nightly+
firefox126 --- fixed

People

(Reporter: boris, Assigned: boris)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

No description provided.
Blocks: 1884425

We treat it as other basic shapes (excluding path(), which has some
special handling and it doesn't rely on the current layout position).

Therefore, we don't have any implementation for caching and we would like to
leave this part to Bug 1837042.

Also, add some more simple tests in css/motion to make sure we render it
properly.

Keywords: dev-doc-needed
Assignee: nobody → boris.chiou
Pushed by bchiou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/232a3ceaa406
Support shape() for offset-path and render it. r=layout-reviewers,emilio
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/45389 for changes under testing/web-platform/tests
Regressions: 1888279
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch
Upstream PR merged by moz-wptsync-bot

:boris could you consider nominating this for a release note? (Process info)
We could include it in the nightly release notes.

Flags: needinfo?(boris.chiou)

Release Note Request (optional, but appreciated)
[Why is this notable]: This is a new feature on Firefox. We support shape() function on offset-path property now. It provides a better CSS syntax for path commands (compared with path(), which uses SVG Path string syntax).
[Affects Firefox for Android]: Yes
[Suggested wording]: Support shape() function on offset-path property.
[Links (documentation, blog post, etc)]:
https://drafts.csswg.org/css-shapes-2/#shape-function
https://drafts.fxtf.org/motion-1/#offset-path-property

relnote-firefox: --- → ?
Flags: needinfo?(boris.chiou)

Thanks, added to the Fx126 nightly release notes, please allow 30 minutes for the site to update.
Keeping the relnote-firefox flag as ? to keep it on the radar for inclusion in the final Fx126 release notes.

Hi Boris, could you confirm if the support for the shape() function in offset-path and in clip-path will be available only in Nightly starting from release 126 (behind the layout.css.basic-shape-shape.enabled preference)?

Flags: needinfo?(boris.chiou)

(In reply to Dipika from comment #9)

Hi Boris, could you confirm if the support for the shape() function in offset-path and in clip-path will be available only in Nightly starting from release 126 (behind the layout.css.basic-shape-shape.enabled preference)?

Yes. Since Fx126, and until now, we support shape function only on Nightly, behind layout.css.basic-shape-shape.enabled.

Flags: needinfo?(boris.chiou)
No longer regressions: 1888279
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: