cookie prompt sheet always displays on current window

VERIFIED DUPLICATE of bug 173844

Status

()

Core
Networking: Cookies
--
minor
VERIFIED DUPLICATE of bug 173844
15 years ago
15 years ago

People

(Reporter: Paul Roebuck, Assigned: Darin Fisher)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.22; Mac_PowerPC)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

The concept of sheets was that they were document-centric; I believe this applies at the 
window level of Mozilla. If preferences are set to ask before cookies are accepted, a 
prompt sheet is displayed in the current window. This is normal when only a single 
window is open. When a link is selected to be opened in a new window, any cookie 
request for that site should have its prompt sheet displayed in the new window. Problem 
occurs when manually simulating Opera's "open in background" browsing. If a link is 
selected (via popup menu) to open in a new window and the new [child] window is 
switched to the background before the page is displayed, the cookie prompt sheet will 
erroneously be displayed on the parent window.

Reproducible: Always

Steps to Reproduce:
1. Select any page with link to site requiring cookies
2. Ensure cookies must be asked before accepted (via preferences)
3. Select 'open in new window' (via popup menu) for above site link
4. As soon as new window appears, reselect original window (which again becomes 
frontmost).

Actual Results:  
Cookie sheet displayed on original [parent] window

Expected Results:  
Cookie sheet should have been displayed on new [child] window
(Assignee)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 173844 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
VERIFIED/dupe
Status: RESOLVED → VERIFIED
QA Contact: tever → cookieqa
You need to log in before you can comment on or make changes to this bug.