Closed Bug 1889438 Opened 2 months ago Closed 1 month ago

Dragging the scrollbar can create a region in screenshots

Categories

(Firefox :: Screenshots, defect, P1)

defect

Tracking

()

VERIFIED FIXED
126 Branch
Tracking Status
firefox126 --- verified

People

(Reporter: niklas, Assigned: niklas)

Details

Attachments

(1 file)

Using the scrollbar to scroll the page while the screenshots UI is open can draw a region on the overlay.
STR:

  1. Open a large page that is scrollable. https://en.wikipedia.org/wiki/Sun
  2. Open screenshots UI
  3. Drag the scrollbar down so the page scrolls (might need to scroll a tiny bit on the page if the scrollbar isn't visible initially)

ER:
No region should be selected because the overlay wasn't dragged

AR:
A region is selected

Pushed by nbaumgardner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84d8a258590a
Dragging scrollbar should not select region in screenshots. r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 126 Branch
Flags: qe-verify+

Reproduced the initial issue using Nightly 126.0a1 Build ID: 20240404034404 on Ubuntu 22.04.

Verified as fixed using the latest Nightly 127.0a1 and Firefox 126.0b5 (having screenshots.browser.component.enabled set to true) on Ubuntu 22.04. Windows 10 x64 and macOS 13.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: