Trunk crash [@ nsXPCWrappedJS::GetInterfaceInfo]

VERIFIED DUPLICATE of bug 188877

Status

()

Core
XPConnect
--
critical
VERIFIED DUPLICATE of bug 188877
15 years ago
9 years ago

People

(Reporter: jay, Assigned: David Bradley)

Tracking

({crash, topcrash})

Trunk
x86
Windows 98
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
There have been quite a few crashes the past few days (since 1/9) on the
MozillaTrunk with this stack signature.  Most of the incidents are on Windows
98, but there are a couple on NT and 2K. Not sure if this is a regression, but
it's worth a look into.  Here is the latest from Talkback:

nsXPCWrappedJS::GetInterfaceInfo   13 
BBID range: 15986520 - 16110736
Min/Max Seconds since last crash: 64 - 29624
Min/Max Runtime: 390 - 189896
Crash data range: 2003-01-09 to 2003-01-13
Build ID range: 2003010308 to 2003011208
Keyword List : 
Stack Trace: 

	 nsXPCWrappedJS::GetInterfaceInfo
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp  line 416]
	 PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp 
line 68]
	 SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp 
line 139]
	 nsDownload::OnStateChange
[c:/builds/seamonkey/mozilla/xpfe/components/download-manager/src/nsDownloadManager.cpp
 line 1184]
	 nsWebBrowserPersist::OnStopRequest
[c:/builds/seamonkey/mozilla/embedding/components/webbrowserpersist/src/nsWebBrowserPersist.cpp
 line 708]
	 nsStreamListenerTee::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsStreamListenerTee.cpp  line 66]
	 nsHttpChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 3018]
	 nsOnStopRequestEvent::HandleEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp  line 213]
	 PL_HandleEvent	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c  line 664]
	 PL_ProcessPendingEvents	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c 
line 597]
	 _md_TimerProc	[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c  line 959]
	 KERNEL32.DLL + 0x2317 (0xbff72317)
 
 	Source File :
c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp line : 416
     (16081568)	URL: www.tvguide.com
     (16059177)	URL: http://www.beautifulwallpapers.com
     (15991587)	Comments: MOZILLA caused an invalid page fault in  module
XPC3250.DLL at 0167:610cd74a.  Registers:  EAX=00000000 CS=0167 EIP=610cd74a
EFLGS=00010246  EBX=00000000 SS=016f ESP=0064f864 EBP=0064f90c  ECX=0064f908
DS=016f ESI=0217abc0 FS=0f0f  EDX=00000036 ES=016f
     (15991587)	Comments:  EDI=0217abc0 GS=0000  Bytes at CS:EIP:  8b 40 0c 85
c0 89 01 75 07 b8 ff ff 00 80 eb 08   Stack dump:  61debd56 0217abc0 0064f908
00000000 0217abc0 00000000 7800cc63 00000009 61dfbf78 00000000 0000004d 8000007e
78000000 78033250 0000003f 00000000 

Adding crash, topcrash keywords and qawanted to see if we can reproduce this.

Comment 1

15 years ago
xpconnect for investigation.
Assignee: dougt → dbradley
Component: XPCOM → XPConnect
QA Contact: scc → pschwartau
(Assignee)

Comment 2

15 years ago
This looks to be a dupe of bug 188877. It should be fixed now.

*** This bug has been marked as a duplicate of 188877 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Marking Verified Duplicate.

What I'm keying off is the reference to nsDownloadManager.cpp,
line 1184, in the stack trace printed above, which was the location
of the fix provided for the other bug -

Dave: good catch!
Status: RESOLVED → VERIFIED
Keywords: qawanted
Crash Signature: [@ nsXPCWrappedJS::GetInterfaceInfo]
You need to log in before you can comment on or make changes to this bug.