Labels are lost when moving to another folder (Courier IMAP)

VERIFIED DUPLICATE of bug 215777

Status

VERIFIED DUPLICATE of bug 215777
16 years ago
10 years ago

People

(Reporter: t8m, Assigned: mscott)

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I see the same problem as in bug 114379, but I didn't want to reopen it.
The labels are lost when moving messages across folders (in the same account).

I use the latest version of Courier IMAP server.

It's either a regression or interop problem.

Comment 1

16 years ago
seeing this too Moz 2003011222 on Mandrake Linux 9.0. 
Anyone seeing this on non-Linux?

Updated

16 years ago
QA Contact: esther → laurel

Comment 2

16 years ago
Not all IMAP servers support storing the labels (and are thereby lost even when
moving them between folders on the same account).

There was/should be a release note item about losing labels accordingly, and not
sure if anyone's logged a bug report about Courier IMAP in particular. 

I would assume this isn't a regression for Courier. It still currently works for
our/Netscape servers.

Will try to run down any bug/doc references.
(Reporter)

Comment 3

16 years ago
The labels support isn't in the IMAP RFCs so they aren't probably implemented in
many IMAP servers except Netscape's own.

Is it done by specifying some special FLAGs on messages? Is there any
documentation on how to properly implement them?

Thanks

Comment 4

15 years ago
Regarding comment #1: Seeing it as well on:
- Windows 2000 Professional
- Mozilla Thunderbird 0.5a (20040120)
with IMAP server:
- Solstice (tm) Internet Mail Server (tm) IMAP4 service @ 2.0.
This is a dupe of bug 215777. I set this one as dupe because bug 215777 contains
more useful informations. If you disagree feel free to reopen it.

*** This bug has been marked as a duplicate of 215777 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

15 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.