Closed Bug 1890428 Opened 3 months ago Closed 2 months ago

Implement Declarative ShadowDOM serialization

Categories

(Core :: DOM: Core & HTML, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
128 Branch
Tracking Status
firefox128 --- fixed

People

(Reporter: avandolder, Assigned: avandolder)

References

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

See the relevant WHATWG issue: https://github.com/whatwg/dom/pull/1256.

Blocks: 1877644
Blocks: 1880714
Pushed by avandolder@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37e2a10a9022
Add shadowrootserializable attribute. r=dom-core,hsivonen
https://hg.mozilla.org/integration/autoland/rev/f9cf0740eef2
Add serialization support for Declarative Shadow DOM. r=webidl,smaug

Backed out for causing wpt failures in idlharness.window.html?exclude=Node

Flags: needinfo?(avandolder)
Pushed by avandolder@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e45e3d15eed
Add shadowrootserializable attribute. r=dom-core,hsivonen
https://hg.mozilla.org/integration/autoland/rev/1954ce9669b8
Add serialization support for Declarative Shadow DOM. r=webidl,smaug

Backed out for causing wpt failures on idlharness.https.html.

[task 2024-05-15T07:41:47.161Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: attribute shadowRootClonable 
[task 2024-05-15T07:41:47.161Z] 07:41:47     INFO - TEST-UNEXPECTED-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: attribute shadowRootSerializable - expected FAIL
[task 2024-05-15T07:41:47.161Z] 07:41:47     INFO - TEST-INFO | expected FAIL
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement must be primary interface of document.createElement("template") 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | Stringification of document.createElement("template") 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: document.createElement("template") must inherit property "content" with the proper type 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: document.createElement("template") must inherit property "shadowRootMode" with the proper type 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: document.createElement("template") must inherit property "shadowRootDelegatesFocus" with the proper type 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: document.createElement("template") must inherit property "shadowRootClonable" with the proper type 
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-UNEXPECTED-PASS | /html/dom/idlharness.https.html?include=HTML.* | HTMLTemplateElement interface: document.createElement("template") must inherit property "shadowRootSerializable" with the proper type - expected FAIL
[task 2024-05-15T07:41:47.164Z] 07:41:47     INFO - TEST-INFO | expected FAIL
[task 2024-05-15T07:41:47.233Z] 07:41:47     INFO - ................................................................................................................................................................................................
[task 2024-05-15T07:41:47.233Z] 07:41:47     INFO - TEST-OK | /html/dom/idlharness.https.html?include=HTML.* | took 2470ms
[task 2024-05-15T07:41:47.235Z] 07:41:47     INFO - PID 2419 | 1715758907171	Marionette	INFO	Stopped listening on port 53208
[task 2024-05-15T07:41:47.805Z] 07:41:47     INFO - Browser exited with return code 0
[task 2024-05-15T07:41:47.807Z] 07:41:47     INFO - Closing logging queue
[task 2024-05-15T07:41:47.808Z] 07:41:47     INFO - queue closed
[task 2024-05-15T07:41:47.827Z] 07:41:47     INFO - Application command: /opt/worker/tasks/task_171575759055922/build/application/Firefox Nightly.app/Contents/MacOS/firefox --marionette about:blank -foreground -profile /var/folders/7w/w8_lzh355ld2fyl0vytvmcf4000014/T/tmp9ppxp_2p
[task 2024-05-15T07:41:47.834Z] 07:41:47     INFO - PID 2426 | 1715758903011	Marionette	INFO	Marionette enabled
[task 2024-05-15T07:41:47.835Z] 07:41:47     INFO - PID 2426 | 1715758903280	Marionette	INFO	Listening on port 53226
[task 2024-05-15T07:41:47.835Z] 07:41:47     INFO - PID 2426 | [ERROR error_support::handling] suggest-unexpected: Error from Remote Settings: Error parsing URL: relative URL with a cannot-be-a-base base
[task 2024-05-15T07:41:47.836Z] 07:41:47     INFO - PID 2426 | console.error: URLBar - QuickSuggest.SuggestBackendRust: "Ingest error: Error from Remote Settings: Error parsing URL: relative URL with a cannot-be-a-base base"
[task 2024-05-15T07:41:47.836Z] 07:41:47     INFO - Starting runner
[task 2024-05-15T07:41:48.165Z] 07:41:48     INFO - PID 2426 | 2024-05-15 07:41:48.164 firefox[2426:67047] Persistent UI failed to open file file:///Users/cltbld/Library/Saved%20Application%20State/org.mozilla.nightly.savedState/window_1.data: No such file or directory (2)
[task 2024-05-15T07:41:48.380Z] 07:41:48     INFO - TEST-START | /html/dom/idlharness.https.html?include=(Document|Window)
Pushed by avandolder@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fb3f0245317c
Add shadowrootserializable attribute. r=dom-core,hsivonen
https://hg.mozilla.org/integration/autoland/rev/d07c0f070f10
Add serialization support for Declarative Shadow DOM. r=webidl,smaug
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch
Flags: needinfo?(avandolder)
Duplicate of this bug: 1886630
Regressions: 1902333
Keywords: dev-doc-needed

FF128 MDN docs for this can be tracked in https://github.com/mdn/content/issues/34302 (just a release note and compatibility data required).

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: