Group digits for disk space/file space sizes

VERIFIED WORKSFORME

Status

P5
enhancement
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: elig, Unassigned)

Tracking

({helpwanted})

Trunk
Future
All
Windows 98
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need info])

(Reporter)

Description

19 years ago
* TITLE/SUMMARY
Please add commas to disk space/file space sizes

* STEPS TO REPRODUCE
0) Launch Mozilla Installer (11.15.99)
1) Pursuant to your platform...
	Mac OS: Navigate to the page with the Typical/Custom pop-up menu.
 Win32: Select a Custom installation, and click "Next"

* RESULT
 - What happened

The listed hard drive space is in a comma-less format, e.g. "1422276 K".

 - What was expected

In a world where 20 Gig hard drives are standard equipment on new computers and
users can have 15343284 K free, it would be clearer to include commas (e.g.
15,343,284 K free) when displaying the numbers.

* REGRESSION

 - Occurs On
        Mac OS Mozilla Installer (11.15.99)
        Win32 Mozilla Installer (11.13.99-ish M11 candidate)

 - Doesn't Occur On
        Mac OS VISE Installer (from Communicator 4.7)

* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 1

19 years ago
setting target milestone to m15

Updated

19 years ago
Summary: Please add commas to disk space/file space sizes → Group digits for disk space/file space sizes

Comment 2

19 years ago
Changing topic from "Please add commas to disk space/file space sizes" to "Group
digits for disk space/file space sizes" for I18N (In German, the meaning of ","
and "." is swapped in comparision to English). Follow OS setting.

Comment 3

19 years ago
moving to M20
Target Milestone: M15 → M20

Comment 4

19 years ago
*** Bug 38471 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
where is installer in the tree?
LordPixel could you help w/ the mac version of this?

windows:
#include <winnls.h>
int GetNumberFormat(
    LCID Locale,	// locale for which number string is to be formatted 
    DWORD dwFlags,	// bit flag that controls the function's operation
    LPCTSTR lpValue,	// pointer to input number string
    CONST NUMBERFMT *lpFormat,	// pointer to a formatting information 
structure
    LPTSTR lpNumberStr,	// pointer to output buffer 
    int cchNumber 	// size of output buffer
   );

LCID should be one of:
LOCALE_SYSTEM_DEFAULT	//Default system locale.
LOCALE_USER_DEFAULT	//Default user locale.

dwFlags should be LOCALE_NOUSEROVERRIDE [i think]
lpFormat should be NULL //the function uses the number format of the specified 
locale.

lpValue

Points to a null-terminated string containing the number string to format. 
This string can only contain the following characters:

·	Characters '0' through '9'
·	One decimal point (dot) if the number is a floating-point value
·	A minus sign in the first character position if the number is a 
negative value

All other characters are invalid. The function returns an error if the string 
pointed to by lpValue deviates from these rules.

lpNumberStr

Points to a buffer to receive the formatted number string.

cchNumber

Specifies the size, in bytes (ANSI version) or characters (Unicode version), of 
the lpNumberStr buffer. If cchNumber is zero, the function returns the number 
of bytes or characters required to hold the formatted number string, and the 
buffer pointed to by lpNumberStr is not used.

Return Values

If the function succeeds, the return value is the number of bytes (ANSI 
version) or characters (Unicode version) written to the buffer pointed to by 
lpNumberStr, or if the cchNumber parameter is zero, the number of bytes or 
characters required to hold the formatted number string. 
If the function fails, the return value is zero.
Keywords: helpwanted
Whiteboard: [need info]

Updated

18 years ago
Depends on: 52052

Updated

18 years ago
Priority: P3 → P5
Changing obsolete M20+ milestones to closest equivalent, "Future"
Target Milestone: M20 → Future

Updated

18 years ago
No longer depends on: 52052

Comment 7

17 years ago
over to Curt.
Assignee: ssu → curt
Status: ASSIGNED → NEW

Comment 8

15 years ago
windows-only
on linux, space is only shown when it is insufficient (<30MB), so proper display
of 2482839 KB is not a problem.
Assignee: curt → general
OS: All → Windows 98
QA Contact: agracebush → bugzilla
Product: Browser → Seamonkey

Updated

13 years ago
QA Contact: bugzilla → general
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 10

10 years ago
> if you still get this with the new installer

... then file a bug against NSIS :).

VERIFIED OUTDATED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.