Last Comment Bug 189170 - Mozilla does not prompt the login alert box dealin a 401-2 server alert instead of a 401-1
: Mozilla does not prompt the login alert box dealin a 401-2 server alert inste...
Status: VERIFIED DUPLICATE of bug 23679
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Darin Fisher
:
: Patrick McManus [:mcmanus]
Mentors:
http://www.viewline.net/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-15 02:39 PST by Yves Lambert
Modified: 2003-01-16 00:15 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Yves Lambert 2003-01-15 02:39:57 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030114
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030114

when the server is asking for authentification, Mozilla does not acknowledge it
and it deals directly a 401-2 error

Reproducible: Always

Steps to Reproduce:
1. load http://www.viewline.net/
2.
3.

Actual Results:  
the server replies 401-2 error and Mozilla doesn't promprt authentification box

Expected Results:  
ack to the server the authentification request and prompt the authentification box.

-> i  mark this as DUPEME. mark it as blocking bug 12578 bug 57529 Bug 134103
and bug 140645 sorry for the spam
Comment 1 Yves Lambert 2003-01-15 02:44:19 PST
-> i submit a new bug. mark it as DUPEME. mark it as blocking bug 12578 and bug
57529 Bug 134103 and  of course bug 61681 sorry for the spam
Comment 2 Olivier Cahagne 2003-01-15 06:36:36 PST
dupe of bug 35159.
Comment 3 Matthias Versen [:Matti] 2003-01-15 07:40:47 PST
HTTP/1.1 401 Acc.s refus...Server: Microsoft-IIS/5.0..Date: Wed, 15 Ja
n 2003 15:34:35 GMT..WWW-Authenticate: Negotiate..WWW-Authenticate: NT
LM..Connection: close

and what Do you mean with DUPME ?
If you know that a bug is a dupe, DON'T REPORT IT.
You will loose your Account if you do that again !

And don't add bug to the depency list if they are unrelated. This generated
useless SPAM.

Thanks



*** This bug has been marked as a duplicate of 23679 ***
Comment 4 Sören 'Chucker' Kuklau (gone) 2003-01-15 07:50:11 PST
1. The problem with that site is that it uses NTLM authentication. This bug has been duped to a bug about implementing that.2. You write:> -> i  mark this as DUPEMEWhy? *Before* filing a bug, watch out if it hasn't already been reported. There's no point in filing a DUPEME bug.> . mark it as blocking bug 12578That has *what* to do with NTLM authentication?> sorry for the spamYeah, indeed. This bug is useless.Verifying duplicate.
Comment 5 Olivier Cahagne 2003-01-15 08:17:46 PST
I'm the culprit for the typo on "DUPME", I meant "DUPEME" and forgot to remove
it when I added comment 2.
Comment 6 Sören 'Chucker' Kuklau (gone) 2003-01-15 08:48:15 PST
Sorry for the lack of line breaks earlier. Blame it on Safari.Olivier, "DUPEME" doesn't make sense when a bug has just been filed.
Comment 7 Olivier Cahagne 2003-01-15 09:07:45 PST
Soren ? It makes sense, it means someone is trying to find the proper dupe and
tell other triagers "don't lose your time on this bug report, someone is taking
care of it".
Once I found the dupe, I mentioned it and forgot to remove "DUPEME".
I knew it was a dupe from the original report (I'm not the reporter) as this is
very common.
If DUPEME is used in another way, please let me know.
Comment 8 Sören 'Chucker' Kuklau (gone) 2003-01-15 09:51:58 PST
I'd say "DUPEME" means "someone find a dupe, I know / am 99% sure there is one
but can't find it".

In this case, the original reporter added that status whiteboard keyword, which
makes it rather pointless (if you know a bug is a dupe when filing it, don't
file it in the first place; try and find the other bug and eventually ask for
help from others).

I thought *you* added the "DUPEME", so my previous comment is wrong anyway.
Comment 9 Matthias Versen [:Matti] 2003-01-16 00:15:00 PST
"dupme" means : I'm sure that this bug is a dupe but I can't find it or i don't
have time. Only triagers should add such a line. 
The reporter should not add such a line because that means that his bug report
is invalid.

Note You need to log in before you can comment on or make changes to this bug.