Open Bug 189313 Opened 22 years ago Updated 4 years ago

Prefs for opening new windows vs tabs and inheriting history

Categories

(SeaMonkey :: Tabbed Browser, enhancement)

x86
All
enhancement
Not set
normal

Tracking

(Not tracked)

REOPENED

People

(Reporter: bugzilla, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

Tabbed browsing increases the number of settings the user may want to customize.
I used NetCaptor for some time and I appreciated very much its capability to set
exactly how you wanted new windows to behave. For example:
                New Window      New Tab      Same window/tab    Inherit History
--------------------------------------------------------------------------------
Javascript
new window()                         X                                 X
External link
(ie from an email,
instant message)                     X                 
URL typed in the
location bar                         X
New window             X                                               X  
New tab                              X                                 X
Click on a link                      X
from the Personal
Toolbar                              X
Search from the 
location bar                         X

I think these are the majority of the possibilities when a new window/tab is
opened, but for sure there may be others. Shown are what I would use as default
(this is, of course, what I use, what else could it be).

I think the Tabbed browsing tab in the Prefs is a good place for this settings
or the smart browsing or a new single browsing tab. Another sugg would be to
change those terms of smart and tabbed and group them in a single (probably)
multitabbed set of options.

I suppose inheriting the history "may be" (depending on how it is implmented,
what I don't know) a memory consumer, but is also a great help as many users
have stated in another bug, and I do too, as I normally use this IE feature, and
so, it should be an option.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
confirming,




and suggesting this be Mozilla Firebird extension.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think this would be important to consider in the regular Mozilla as well, not
just Firebird.  I would like the ability in preferrences to default/set how the
opening in windows behave, especially opening a target="_blank" in a new tab not
a new window.
Does the owner of this component want to weigh in on this?  I'd really like to
see this.  I think there are other bugs that cover parts of this proposal, so
this should either be marked as a dup or discussion ought to begin.

Owner, or someone special should switch this bug's OS to all.
Does the owner of this component want to weigh in on this?  I'd really like to
see this.  I think there are other bugs that cover parts of this proposal, so
this should either be marked as a dup or discussion ought to begin.

Owner, or someone special should switch this bug's OS to all.

Because of language limitations I guess, I don't think I understand what does
"weigh in" mean. Please clarify.

As for the OS, yes it is not specific to NT, so I changed it to All.

As for the dup suggestion. In fact, I posted this bug after reviewing several
similar, in an attempt to streamline all those here, in a more general feature.
OS: Windows NT → All
Summary: New windows/tabs behavior → Prefs for opening new windows vs tabs and inheriting history
Depends on: 18808
Product: Core → SeaMonkey
Assignee: jag → nobody
QA Contact: pmac → tabbed-browser
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → EXPIRED
Ever confirmed: true
Bugs with this many votes probably shouldn't be EXPIRED.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---

First time an URL is being opened from a desktop, it evokes SeaMonkey's total restored session. Every next URL outside the browser opens a new window. I suggest this should be the case for the first time too. And the restored session should be opened either on demand, or when the application is started as is (e.g. from a Start Menu shortcut to the bare programme without input)

You need to log in before you can comment on or make changes to this bug.