mozilla doesn't completely exit

VERIFIED FIXED in mozilla1.3beta

Status

SeaMonkey
General
--
blocker
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({smoketest})

Trunk
mozilla1.3beta
x86
Windows 2000
smoketest

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.62 KB, patch
Christopher Aillon (sabbatical, not receiving bugmail)
: review+
blizzard
: superreview+
Details | Diff | Splinter Review
mozilla doesn't completely exit

at least not in my debug build
Keywords: smoketest
My opt Linux build exits fine.
I'm seeing several NS / Mozilla processes hanging around in win2k.

Comment 3

16 years ago
I see this too on windows 2k only after running mailnews.

Comment 4

16 years ago
More specifically, it only seems to hang if I open a newsgroup. I noticed some
stylesheet changes for the folder pane for a Junk folder (which doesn't show
up), perhaps related???

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/2003011704
caused by a warnings fix that I made.

patch coming.

curse me!
Assignee: asa → sspitzer
Target Milestone: --- → mozilla1.3beta
Comment on attachment 111857 [details] [diff] [review]
patch

sr=blizzard
Attachment #111857 - Flags: superreview+
fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Comment on attachment 111857 [details] [diff] [review]
patch

>-  for (PRUint32 i = count - 1; i >= 0 ; i--)

>+  for (PRUint32 i = count; i != 0 ; i--)


Any particular reason for going from >= to != (it seems that > is more standard
practice with things like this, but your call).

r=caillon
Attachment #111857 - Flags: review+
*** Bug 189450 has been marked as a duplicate of this bug. ***
*** Bug 189512 has been marked as a duplicate of this bug. ***
verified fixed with 1pm respins on mac osx and windows
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
*** Bug 189521 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.