Closed Bug 1896097 Opened 14 days ago Closed 10 days ago

[macOS] Text in the crash reporter dialog is not localized for the non-US FF builds

Categories

(Toolkit :: Crash Reporting, defect)

All
macOS
defect

Tracking

()

RESOLVED FIXED
128 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox125 --- unaffected
firefox126 + fixed
firefox127 + verified
firefox128 --- verified

People

(Reporter: cgeorgiu, Assigned: afranchuk)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Found in

  • 126.0 RC2

Affected versions

  • 127.0a1 Nightly
  • 126.0 RC2

Tested platforms

  • Affected platforms: macOS 12, macOS 13
  • Unaffected platforms: Windows, Ubuntu

Preconditions

  • Have a localized build downloaded, e.g. "it", "fr" or "de".
  • The build is installed on the test machine.

Steps to reproduce

  1. Launch Firefox.
  2. Go to "about:crashparent" in a new tab.
  3. Pay attention to the text inside the crash reporter dialog

Expected result

  • The text inside the crash reporter dialog is accordinagly translated to the tested build ("it", "fr" or "de").

Actual result

  • The text inside the crash reporter dialog is not translated to the tested build ("it", "fr" or "de").

Regression range

  • It seems that the issue is not repro with Firefox 125.0.3. I will investigate further asap in order to find a regression range.
Assignee: nobody → afranchuk
Status: NEW → ASSIGNED

The crash reporter binary is in a different location in macOS installations, so it cannot locate the omnijar.

Keywords: regression

I have a fix for this. It is cumbersome to verify since it changed a portion of shared code and I want to verify that other platforms are not affected. I'm verifying now.

The branding was also potentially not read correctly (from the browser
omnijar) as a result of incorrect merging of changes from another
commit, however the impact of this is far less as the branding is likely
similar across locales.

QA Whiteboard: [qa-regression-triage]

(In reply to Ciprian Georgiu, Desktop QA from comment #0)

Regression range

  • It seems that the issue is not repro with Firefox 125.0.3. I will investigate further asap in order to find a regression range.

I can reproduce the bug after the landing of https://bugzilla.mozilla.org/show_bug.cgi?id=1759175 in Nightly 125.0a1 (2024-03-08). With a pre-patch Nigthly build (2024-03-06), I cannot reproduce the issue. Unfortunately, I cannot pinpoint for sure the exact bug since I had to manually do the regression range.

Although this is already assigned, I hope this info helps.

Has STR: --- → yes
Regressed by: 1759175
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/080acbd234b3
Fix location of the omnijar file(s) on macos r=gsvelto
Status: ASSIGNED → RESOLVED
Closed: 10 days ago
Resolution: --- → FIXED
Target Milestone: --- → 128 Branch

Comment on attachment 9401120 [details]
Bug 1896097 - Fix location of the omnijar file(s) on macos r=gsvelto

Beta/Release Uplift Approval Request

  • User impact if declined: The crash reporting dialog is not localized
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Download a localized build
  1. Run Firefox and crash it by navigating to about:crashparent
  2. Check if the crash reporting client opens and is localized in the same language as Firefox
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): We tested the patch thoroughly during development, but this code affects Windows, macOS and Linux differently. There's a fair bit of complexity involved.
  • String changes made/needed: none
  • Is Android affected?: No
Attachment #9401120 - Flags: approval-mozilla-release?
Attachment #9401120 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Set release status flags based on info from the regressing bug 1759175

Comment on attachment 9401120 [details]
Bug 1896097 - Fix location of the omnijar file(s) on macos r=gsvelto

Approved for 127.0b2

Attachment #9401120 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-regression-triage] → [qa-regression-triage][qa-triaged]

I've confirmed that this issue is fixed in the latest Nightly 128.0a1 ("zh-TW", "it", "de") on macOS 13. I'll verify on Beta 127 as well once the localization builds are available.

Donal, I assume you intended to change the flag to fixed in FF 127, not 126.

Donal, I assume you intended to change the flag to fixed in FF 127, not 126.

Yes, thanks. Corrected!

This is also verified as fixed on Beta 127.0b2 ("de", "fr" and "it" builds) on macOS 13.

Flags: qe-verify+

Thank you for the testing & uplifts 🙏

Comment on attachment 9401120 [details]
Bug 1896097 - Fix location of the omnijar file(s) on macos r=gsvelto

Approved for 126.0.1

Attachment #9401120 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: