didn't open windows onclose function at body

VERIFIED DUPLICATE of bug 130719

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 130719
15 years ago
15 years ago

People

(Reporter: Dmitry Trofimov, Assigned: Dmitry Trofimov)

Tracking

Other Branch
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1) Gecko/20021225
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.1) Gecko/20021225


this html code in the frame 
<body
onUnload="window.open('Account.pl?func=chat_exit&room_id=1','lalala','status=no,toolbar=no,menubar=no,scrollbars=no,top=2500,left=2500,screenX=2500,screenY=2500,width=1,height=1');">

new window didn't appear.
javascript console: 

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: onunload ::
line 0"  data: no]

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
window opens

Comment 1

15 years ago
Work for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030119. This bug is dupe of bug 166654, fixed in bug 130719.

Dupe of bug 130719?

Comment 2

15 years ago
please don't file bugs with browsers more than one release old (this was fixed
by 1.2)
Assignee: rogerl → dmitry
Component: JavaScript Engine → Event Handling
Version: Trunk → Other Branch

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 130719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Setting default QA and marking Verified Duplicate -
Status: RESOLVED → VERIFIED
QA Contact: pschwartau → trix
You need to log in before you can comment on or make changes to this bug.