Printing a XUL slider crashes browser in Classic theme [@ nsPrintEngine::ReflowPrintObject]

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: chuckie, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030119
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.3b) Gecko/20030119

If the Classic theme is active, printing a XUL document with a <slider> will
crash the browser. Setting the enclosed <thumb>'s CSS -moz-appearance property
to "none" prevents the crash. The crash doesn't happen at all in the Modern theme.



Reproducible: Always

Steps to Reproduce:
1. Switch to the Classic theme
2. access the attached printcrash.xul document
3. print this document.

Actual Results:  
Browser crashed.

Expected Results:  
Printed the document.

Talkback crash ID: TB16399880E

Updated

17 years ago
Blocks: xulprinting

Updated

17 years ago
Keywords: crash, stackwanted
Whiteboard: TB16399880E

Comment 2

17 years ago
Posted file stacktrace
from linux trunk CVS (today)

Comment 3

17 years ago
marking NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwantedtestcase
Summary: Printing a XUL slider crashes browser in Classic theme → Printing a XUL slider crashes browser in Classic theme [@ nsPrintEngine::ReflowPrintObject]

Comment 4

16 years ago
WTF with 2003-03-27-08-trunk - should be fixed now...

Comment 5

16 years ago
I still crash with linux trunk 20030330

Comment 6

16 years ago
Andrew Schultz wrote:
> I still crash with linux trunk 20030330

Printing PostScript module or Xprint module ?

Comment 7

16 years ago
I now crash with print preview (which should be using XPrint), but not print
(XPrint and Postcript both work).

Comment 8

16 years ago
It's also crashing with 2003091510/trunk/W2K -> TB23659746M
xref: bug 219410 - print preview of about:config is crashing (with same crash
signature)
OS: Linux → All
Whiteboard: TB16399880E
about:config is bug 218304
Blocks: 218304
no crash currently.  receive message "We are unable to Print or Print Preview
this page."  
Assignee: hyatt → nobody
QA Contact: shrir → xptoolkit.xul

Updated

11 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets

Comment 11

10 years ago
Yeah, that's because of the sketchy fix in bug 240490.

It's possible that something like this still crashes when inside an HTML document.  But Martijn Wargers has been testing print / print preview really hard, so if this bug still existed when he started I bet it's gone by now.

I'll add this testcase as crashtest, just to be sure.  I'll use reftest-print if the framework lets me.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 12

10 years ago
Using reftest-print seems to get around the fix in bug 240490, triggering assertions like:

###!!! ASSERTION: XUL documents should never be scrollable - see above: '!isScrollable || !isXUL', file /Users/jruderman/central/layout/base/nsCSSFrameConstructor.cpp, line 2853

###!!! ASSERTION: Unexpected PopupSetFrame: 'nsIRootBox::GetRootBox(mPresShell) && nsIRootBox::GetRootBox(mPresShell)->GetPopupSetFrame() == newFrame', file /Users/jruderman/central/layout/base/nsCSSFrameConstructor.cpp, line 3903

So I'll add this as a normal crashtest.
Crash Signature: [@ nsPrintEngine::ReflowPrintObject]
You need to log in before you can comment on or make changes to this bug.