Open Bug 1898570 Opened 25 days ago Updated 14 days ago

Pull in Glean v60.3.0

Categories

(Data Platform and Tools :: Glean: SDK, task, P1)

task

Tracking

(Not tracked)

REOPENED

People

(Reporter: janerik, Assigned: janerik)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

No description provided.
Pushed by jrediger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/78257216533d
Update to Glean v60.2.0 r=chutten,supply-chain-reviewers,mach-reviewers,android-reviewers,tthibaud
Status: ASSIGNED → RESOLVED
Closed: 20 days ago
Resolution: --- → FIXED

Backed out from central for breaking fenix builds.
Backout link: https://hg.mozilla.org/mozilla-central/rev/046da0f065e90bcf67ec9fd58aa8f84c1a8f80be

Flags: needinfo?(jrediger)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file log
updating the glean version led to app launch failures. the proccess would try to start 5 times and then quit. Here is a log of a single attempt (they were repeated exactly same)
Attached file glean_problem_log.rtf

updating the glean version led to app launch failures. the proccess would try to start 5 times and then quit. Here is a log of a single attempt (they were repeated exactly the same)

I can't reproduce any issue locally and I don't see anything in that short log that would indicate a problem (no crash, no real error logged).
Was this a task on CI? If so please link to it directly so I can take a look.
If not what steps did you do to launch it?

Flags: needinfo?(jrediger) → needinfo?(mavduevskiy)
Attached file full_log.rtf

Steps to reproduce:

  1. apply the reverted patch
  2. launch the firefox app.

Expected behaviour:
app launches
Actual behaviour:
I watch animated logo for 5-7 seconds, then it freezes for good.

Attaching full log.

Flags: needinfo?(mavduevskiy)

That does have a crash, but unfortunately not much debugging info. But it does point to uniffi_glean_core_fn_func_glean_initialize, so something clearly funky is going. I'll investigate further.

Summary: Pull in Glean v60.2.0 → Pull in Glean v60.3.0
Attachment #9403576 - Attachment description: Bug 1898570 - Update to Glean v60.2.0 r?chutten! → Bug 1898570 - Update to Glean v60.3.0 r?chutten!
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: