[ps] postscript output only print an error message, not page

RESOLVED FIXED

Status

()

Core
Printing: Output
--
major
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Erwan David, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030120
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030120

When trying to print any page on a Laserjet 4050, trhe output is an error
message about a too old postscript interpreter (2014.116 instead of 2015 or
greater). A hack using gs is suggested, but this makes printing slow and non
portable.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
printing of one sheet with hack to print

Expected Results:  
print the page
(Reporter)

Comment 1

16 years ago
the suggested hack 
gs -q -sDEVICE=pswrite -sOutputFile=- -dNOPAUSE -dBATCH
-dMozConvertedToLevel2=true|lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}

does not work either (nothing is printed)
(Reporter)

Comment 2

16 years ago
Bug seems to have disapeared from latest nightlies

Comment 3

16 years ago
Reporter:
Using Mozilla's Xprint module should work perfectly with your printers - see
http://www.mozilla.org/releases/mozilla1.0.2/#xprint
Summary: postscript output only print an error message, not page → [ps] postscript output only print an error message, not page

Comment 4

16 years ago
I know that Xprint works but after I upgraded mozilla from 1.2 to 1.3 here I got
lots of calls from **** off users because suddenly printing stopped working
(we're mostly using Solaris on sparc with a few Linux machines).
It printed only this annoying error page on most of our printers whereas it
apparently worked in 1.2. Why was the postscript module "fixed" in this way?
It certainly wasn't perfect but at least it printed most of the stuff people
wanted here. Now it's almost completely unusable and I have to educate my users
how to start Xprt and use Xprint (fortunately the Solaris Xprt seems to work
fine out of the box, Linux is a different story). So, please either revert the
postscript module back to the 1.2 state or give users at least an option to
print on a level 2 printer instead of **** them of with an annoying error page.

just my 0.02c.
I can confirm this at least for 1.3. As long as Xprint is not the default (is
it?), printing should work on Postscript Level 2 printers.

Comment 6

15 years ago
I have the same problem here with Mozilla 1.6 and an Kyocera FS-800 under Linux.
If I use lpr/kprinter directly, it prints an error page

"The Postscript interpreter in your printer is 2014.108
This printout requires at least version 2015 or greater"

If I use the ghostscript hack provided on the error page, it just prints a page
with garbage characters.

Comment 7

14 years ago
Is this fixed with the checkin for Bug 182324?

Comment 8

13 years ago
This should have been fixed by the checkin for bug 234182. At the very least the
behavior should be different, because the postscript version check code was removed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 9

13 years ago
*** Bug 324539 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.