A crash occurs when quiting during a file transfer in DL manager (@nsDiskCacheOutputStream)

RESOLVED DUPLICATE of bug 189779

Status

SeaMonkey
Download & File Handling
--
critical
RESOLVED DUPLICATE of bug 189779
15 years ago
4 years ago

People

(Reporter: Chris Petersen, Assigned: Darin Fisher)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Build: 2003-01-20-08 CFM trunk
Expected Results: Application should simply quit with crashing
What I got: Upon exiting, the application crashes

Steps to reproduce:

1) Specify DL manager to open as default
2) Go to http://www.macupdate.com/info.php/id/263
3) Click on 'Download Now' link. Save the file.
4) DL manager should display the file transfer
5) While this transfer is occuring, go back the page and click on second link
'Download Site 2'. Save the file.
6) Notice the second dl doesn't appear in dl manager.
7) Now, press command-Q to exit the application.
8) During the process of quitting, the application crashes.
(Reporter)

Comment 1

15 years ago
Created attachment 112231 [details]
stack trace from Console.app
to darin; didn't you just fix this?
Assignee: blaker → darin
Whiteboard: DUPEME
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 189779 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.